xcode

  1. clee2005

    Job Offer - Programmer Please Delete

    Is there no ability to delete a post?
  2. clee2005

    iOS Altering Linker Flags in Xcode builds

    In GMS 1.4 I was able to alter the project.pbxproj file to remove the "all_load" LDFlag for building my iOS projects. When GMS did it's iOS build, it would create a project without this flag. One of the extensions I use requires it to be removed from the Other Linker Flags section in Xcode...
  3. V

    Admob not working on ios?

    When i try to compile in Xcode(the most recent version), i get tons of errors that seem to revolve around the admob extension. When i comment out all the ad code, and remove the extension, the game compiles just fine. Is it still possible to use admob in gamemaker studio 1.4?
  4. R

    iOS builds and Xcode

    So with apple rolling out iOS 11 and xcode updating to a new version. I was just wondering if there was any word on yo yo game updating the iOS exporter. Currently the games will build to the phone but with problems such as sounds and some other crash bugs. I hope that yoyo will be able to...
  5. P

    iOS Mach-O Linker Error

    Hi All, 1st post, be rude if you want just be helpful ;) I've no exp with GMS, iOS or Xcode but when trying to test my game I'm falling over with the following errors. I'm guessing it's a matter of tweakin' something but hav no idea what or how. all help gratefully received. Undefined symbols...
  6. TheOnlyWRT

    iOS Bad Access on Thread Freezes App

    Hello there! So, I am working on an iOS app and it loaded up on my phone the first time i built it no problem. Then, i changed the app icon and built the app again and it said that it worked, but the icon didnt change, and now it gets a "bad access" warning (see photo below) and the app freezes...
  7. S

    Xcode Linker command failed (GoogleAnalyticsServices)

    Hi, After updating Xcode to the latest, I'm unable to build my project (I was previously able to) ld: ;library not found for -lGoogleAnalyticsServices clan: error: linker command failed with exit code 1 I already deleted and re-imported the latest GoogleAnalyticsExt.ext from Yoyogames Any...
  8. TheOnlyWRT

    iOS Has Anyone Else Had This Error?

    Hey guys, so I have the mobile license, but GMS2 keeps getting an error and will not build my game in Xcode. It doesnt make an xcode project for my app, so the app wont build and yeah..... so i cant make iOS apps right now. Here is what the output says when i build the game in GMS2 (i...
  9. TheOnlyWRT

    iOS iOS Not Running Smoothly

    Hey guys, so I am on a new MacBook Pro and am developing with GMS2 for iOS. I have seen something interesting lately. My game has made it to a certain point, and then when add new features, they dont show up on my iPhone, even though GMS2 says that it built correctly... in an attempt to fix...
  10. TheOnlyWRT

    Trying to get iOS Development working

    Hey guys, so i have downloaded all the certificates and what now for iOS development, the code signing on Xcode checks out, my device is registered, but when i click run in GMS2, it takes it to Xcode and gets an error that i have no idea what it means..... there is an attached picture. Does...
  11. luisog30

    Creating a Macbook Pro Touchbar .dylib extension

    Hello, I have a 2016 MacBook Pro with TouchBar model and I'm developing a game for Windows and Mac using GameMaker Studio 2, which, as all of us know, allows you to add extensions created with another programs. When using Mac OS X, GameMaker needs an extension of type .dylib, which includes the...
  12. MrDave

    iOS Problem on iOS when using network_ functions with TCP.

    I have an iOS game that uses network_create_socket() and network_connect_raw() and it all works fine when I put it on an iPhone and run it (either through Xcode or Test Flight) It even runs fine on the simulator on my Mac. However when I submit it to the Apple iTunes store they E-mail me a crash...
  13. Z

    iOS Duplicate Symbol in XCode

    Hi, I tried to export XCode project with YYC compiler and I got linking error when I compile. duplicate symbol _gs_ret27 in: ../gml_Object_obj_player1_Draw_0.gml.o ../gml_Object_obj_player2_Create_0.gml.o In the source code file of .gml file, that variable is defined under #ifndef...
  14. D

    How to update SDK

    Hello! Im trying to upload a new game to Apple Store and I receive this messages: Missing Info.plist key - This app attempts to access privacy-sensitive data without a usage description. The app's Info.plist must contain an NSBluetoothPeripheralUsageDescription key with a string value...
  15. kryneon

    iOS Xcode couldn't find a provisioning profile matching

    Could someone please help me with this compile error? • GM 1.4.1763 • MAC OS X 10.11.6 • Xcode 8.21 • iPhone 5 OS 10.2 I've replaced the name of my game with "game" I can confirm through Xcode that my device has the profile installed on it, and the Mac also has the profile in...
  16. C

    iOS capabilities (Thinning, Handoff, SpriteKit...)

    I am filling out a form for Apple to be featured and was not 100% sure on a few iOS capabilities. Size: My app on Andoird is approx. 60MB and for iOS is comes out to be about 120MB are there any tricks to get the app under 100MB? Is app thinning the only option here, if so how do you enable app...
  17. J

    iOS Error in xcode when running iOS version

    I just bought a Apple Developer account and want to export my game to iOS. I have set the bundle identifier and successfully connected to my mac, running my game "Mac OSX (YYC)" works perfectly. but when I choose iOS it creates a new xcode project and when I'm trying to run that I get this error...
  18. Samuel Venable

    Legacy GM Apple TV and Apple Watch

    Is it possible to create Apple TV/Watch games via tweaking the iOS module setup in XCode? Is there any way to convert an iOS app into an Apple TV/Watch app?
  19. D

    iOS App icons not populating to Xcode project

    Hey all, I've got an existing project which has been published and updated many times to the App Store on iOS. Not sure if this is related, but I recently updated to Xcode 8.1. Everything seemed to work great, but I just noticed that my Xcode project only has 3 of the app icons filled in and...
  20. papadar

    Xcode 8.1 EXC_BAD_ACCESS (code=1, address=0xd8) error

    Hi all ! i'm running Gamemaker studio v1.4.1763 on win7 I got the attached error in xcode after exporting my latest build to xcode 8.1 ( macos 10.12.1 ) after trying to track this down in my own code, I made an entirely blank project & get the same error when exporting to xcode the game loads...
Top