xcode

  1. Architheutis

    iOS Xcode and few problems left to be solved - who can help?

    Hi there! Well... learning by doing is a wise and an effortfully way. I thank the few of you, who helped me before. Now I´ve got the feeling that I am close to the goal. But there are few things left to be solved, I still need a hint of an experienced one, here. Here are the facts: - created...
  2. Architheutis

    GMS2 (WIN) can´t connect with my MacBook (via GMS2s device detection)

    Hello everybody, I´m working on publishing my game app on App Store, too. But as the headline already says: Game Maker Studio 2 cannot detect my MacBookPro. Following conditions are given: - Gamemaker Studio 2 runs on my PC (WINDOWS 10 Pro) - MacBook Pro is running Catalina 10.15.6 - Both...
  3. meltypixel

    GMS 2.3+ 2.3 YYC Mac build Xcode error: Unknown type name 'var'

    I recently upgraded to GMS 2.3, and I'm running a separate install of the beta just in case I needed to roll back easily. I'm attempting to export with YYC, but I'm getting an Xcode error: Unknown type name 'var' in the very first piece of code that the game attempts to compile. This game...
  4. A

    iOS Bug when launching landscape app on iOS 13

    Hello, This might seem a bit off topic but I’ve found no other place where I could ask for help and you would do me a HUGE favour if you could help me out. Due to the new App Store requirements, I am forced to update some of my older projects that I want to keep alive. One of those projects...
  5. Mookal

    SOLVED iOS Export: Connection Successful, No Devices Found

    I'm developing my game on my Windows PC, and I have a Mac set up with Xcode for testing the iOS export. I hadn't tested in a while so I tried to send a build to the Mac, but I kept getting the "FAILED: Run Program Complete" error. I then tried to search for iOS devices connected to the Mac...
  6. R

    Mac OSX Notarized MacOS app "unable to find game"

    I did the whole process of codesigning and notarizing a game .app for MacOS so I can distribute it outside the App Store. I've signed, notarized, and exported the game on my computer. I confirmed that opening the original exported .app file works just fine, the game runs. However if the app is...
  7. Pedro Jones

    iOS iOS large memory usage

    My game is very optimized and it doesn’t have any memory leaks on Android, but on IOS (with Xcode 11) it constantly receive memory warnings and after a while it closed. I checked the memory usage of my game with the debug tools and I got the next results: 39 MB of memory usage for Android and...
  8. S

    iOS Problem with iOS Export

    Hey everyone! I've exported to iOS successfully many times before, but today I've just started to get this problem. When exporting to iOS I get the error: Renci.SshNet.Common.ScpException: scp: error: unexpected filename: at Renci.SshNet.ScpClient.CheckReturnCode(Stream input) at...
  9. C

    How to add arguments to command line for iOS builds with GMS?

    I'm trying to run my iOS build with the following command line argument in Xcode : -FIRDebugEnabled. Every time I build with GMS, I must do the following in Xcode: In Xcode, select Product > Scheme > Edit scheme... Select Run from the left menu. Select the Arguments tab. In the Arguments...
  10. RizbIT

    DON'T USE THIS CODE AS IS! IF EVERYONE USES THE SAME CODE

    After compiling iOS app from GMS PC to Mac's Xcode I see these warnings in XCode #ifndef YES_I_HAVE_READ_THE_WARNING_AND_I_ACCEPT_THE_RISK #warning --- DON'T USE THIS CODE AS IS! IF EVERYONE USES THE SAME CODE #warning --- IT IS PRETTY EASY TO BUILD AN AUTOMATIC CRACKING TOOL #warning --- FOR...
  11. gokhang

    iOS xcode fremework not found error

    Hi friends, There is a problem. game maker studio 2 (2.2.1.375) mac os version: os x yosemite 10.10.5 xcode version: 7.0(7a220) error: xcode fremework not found error. how to fix this? Thanks.
  12. witches

    Distribution [SOLVED]MacOS Export "Unable to find game!!" When openned from downloaded directory

    I'm actually going insane. I exported my code via YYC and is interpreted in xcode flawlessly. Game runs perfectly on my Mac through Xcode and I have an Apple Developer membership. I have a certificate for the Developer ID Application I have a unique registered identifier for my game I have an...
  13. D

    Mac OSX Your license does not have this module enabled

    Hi I wanted to give a try with gms2 and I installed the trial version on Mac Catalina with the mono framework and the last Xcode but I have always this message "Your license does not have this module enabled" when I try to run the game . Runtime is 2.2.5.378. I tried to clean cache... log out...
  14. B

    IO's and exporting error

    Hi I trying to export my game on IO's and I getting error: linker command failed with exit code 1 I created empty project and project push me the same error as my final game, project working on Android, Mac and Windows very well, i tried everything, any ideas? More details about error...
  15. WWAZman

    iOS Admob.h not found

    nevermind
  16. clee2005

    iOS Reading iOS crashes in Xcode

    Hey GMer's, I've been looking at the errors coming in to Xcode from our games and wondering if there is any documentation discussing the mapping of Xcode errors to GML code in the roughest of senses of course. When tracking a bug down like the one below, it can be very helpful to get a rough...
  17. A

    iOS Testing to iOS

    I am trying to learn how to build for iOS, but am running into complete blocks with Xcode. Just trying to run a simple black box "game" that doesn't have any movement, build fails in Xcode. I run into two problems: Error: Command CodeSign failed with a nonzero exit code warning: User supplied...
  18. QatariGameDev

    iOS Cannot build iOS game through Xcode ? [SOLVED]

    Hello, For odd reason, I can compile and export just fine through GMS 2 (windows) to xcode project. But when loaded on my mac Xcode, I see this in the "identity" like it's missing informtion from "info.plist" How i can fix this ? I was able to export and compile iOS build just fine last...
  19. B

    iOS Thread 1: signal SIGABRT

    Hi! When I export my game to my iPhone, it runs pretty good. But when I try to run on a iPad, the xcode gives a "Thread 1: signal SIGABRT" error. I don't know what is the problem.
  20. E

    iOS Error Xcode Invalid bitcode signature GM (GPS-ADMOB)

    Good afternoon I have a project in GM 2.2.1 and a project that when exporting it to Xcode can build without problems, the problem occurs when I add the Google Play services extension of the Market... GM 2.2.1 XCODE 10.1 Showing Recent Messages Ld...
Top