windows 10

  1. M

    Steam Test Button WILL NOT WORK

    Test Button WILL NOT WORK So I'm having a bit of an issue ever since I purchased this from steam the Test button when I want to check out something doesn't work. The Free version on the GM site works but the professional version that I purchased on steam some time ago doesn't, I'm on windows 10...
  2. R

    Windows Sharing Alpha Builds / Windows SmartScreen Stops Them

    I'm trying to get my game out there and playable but when I share a download of a single runtime executable SmartScreen will stop it. I have Gamemaker Studio Professional and this has worked in the past. Windows must have changed their security. What do any of you suggest I do?
  3. T

    Can't find any sprites I downloaded

    So, I downloaded a ton of sprites and things from the marketplace, and they cannot be found anywhere. I went through every single possible place they could be, and there is no sprite folder anywhere, nor is there a sound folder anywhere. there are only those files in my project files, but it is...
  4. P

    [SOLVED] Blurry GM8 200% scaling

    I'm currently trying to run the game fixed in 200% scaling with interpolation off but I'm still presented with the same issue. The image on the left is the expected output but when using 200% scaling the image becomes blurry (right). Any help would be appreciated.
  5. C

    Death animation/cycle not working properly? Problem with destroy event.

    Hi all, so I'm making a little test game to get back into Game Maker, and I'm having trouble with a death animation. The idea is I have this little alien that is supposed to die when it falls in lava. Specifically, it's supposed to: 1. Collide with a "lava_surface" object 2. Be transported 10...
  6. D

    Windows Windows Defender detects my app as a virus.

    Hello Im working on many projects on GameMaker and Im releasing them on my personal webpage to public. But I have a problem here. Users that use Windows 10 can't even download the .exe file. They get a warning from SmartScreen Filter and Windows Defender. Some people doesn't even want to...
  7. R

    Windows fps drops on full screen, direct play & Windows 10

    Hello. I use Game Maker since years ago, first GM8 and now GMS. I never experienced this problem before until I upgraded from Windows 7 to Windows 10. The games run fine in a window, but on full screen there is a serious lag, with constant micro-stops every few seconds. The first time this...
  8. W

    Shader not applying effect

    Hi, in my game for windows pc I have 2 shaders, 1 for blurring and one for color to black and white, theres no compile errors but neither shader applys the effect, in my draw event if i comment out the else draw_self() the sprite is invisible, but when i use the shader the sprite becomes visible...
  9. Cpaz

    Legacy GM Windows (YYC ) on Windows 10

    Having issues atm with trying to test a project with the YYC compiler on Windows 10. All settings are "ok", i've installed Visual studio community (what I used on a windows 7 laptop and have it work just fine) Upon compiling I get this sort of error repeatedly, but with different scripts. In...
  10. mariospants

    Windows SmartScreen on startup: how to avoid this

    Sorry if this has been resolved before, but the new Forum Search doesn't come up with anything to do with SmartScreen. When running a GameMaker game for the first time on Windows 10, invariably you encounter the Windows SmartScreen error: Which sucks. For us neophytes, how do we register...
  11. H

    Legacy GM Game works WORSE when standalone EXE

    Hi everyone! This is my first post in these forums. I'm quite a newbie using Game Maker but I'm getting the hang of it pretty quickly. Some days ago, I crashed my computer and I had to restore it. I was using Windows 8.1 and I thought that, as I had to reinstall an OS anyway, I'd use my gift...
  12. S

    Windows Games going black screen on Windows 10?

    As you may know, a lot of GameMaker games have a black screen at random on Windows 10 while playing in fullscreen. It doesn't appear to happen to everyone, though, and I have no idea what's causing it. Usually playing in windowed mode fixes it. This issue is present through a lot of commercial...
  13. JML

    UWP YYC "error LNK2001: unresolved external symbol" / "fatal error LNK1120: 1 unresolved externals"

    Greetings this is a follow onto a previous thread i made. the yyc compiler is not working, previously i thought the problem was due to an in game iap but i attempted to remove it and compile and it failed when trying to compile the create event of the first object in the game which only have...
Top