visual studio

  1. Pelican Police

    SOLVED [GMS YYC] Batch file not found at Visual Studio path

    I'm having trouble trying to get YYC to work on windows 10. I've followed everything people said to do in this discussion: https://forum.yoyogames.com/index.php?threads/yyc-and-windows-10.4023/ but I just get this error: If I do a manual search in that folder, there are plenty of batch files...
  2. EvanSki

    SOLVED What install options do I install in Visual Studio 2019 to setup the YYC compiler?

    As the name says, what install options do I need to install to get the compiler to work, as the example https://help.yoyogames.com/hc/en-us/articles/235186048-Setting-Up-For-Windows is for Visual studio 2017 2017 2019 I want to use 2019 as It seems wise to use up to date products...
  3. jb skaggs

    Windows GMS 2 MS windows controls and VB DLL's

    I recently wrote an WPF application for a friend I met here on Gamemaker. I was curious how gamemaker could to the same thing: I could not get game maker to communicate with DLL written in Visual Studio. I read a lot posts about this and it seems external files have been deprecated- I...
  4. kamiyasi

    Downloading Microsoft Visual Studio 2012

    Hi, I just reinstalled Windows 10 on my desktop, and I'm looking for a way to install MVS2012 again so I can continue using the Windows YYC platform. I've installed Visual Studio Community 2017, but if I remember, only MVS 2012 is compatible with 1.4
  5. K

    Windows YYC compiler and Visual Studio 2017

    Hello, I have a problem executing my game with the compiler yyc. I have Game Maker studio 2, Current Runtime = 2.1.2.172, Windown 10 and Visual Studio 2017. when compiling I get the following message: Microsoft (R) Windows (R) Resource Compiler Version 10.0.10011.16384 Copyright (C) Microsoft...
  6. K

    Compiler yyc with VS 2017

    Hello, I have a problem executing my game with the compiler yyc, I get the following message "compile failed - please check the compile window for any additional information", my configuration is as shown in the image. I have Game Maker studio v1.4.1772, Windown 10 and Visual Studio 2017. Excuse...
  7. B

    Question - IDE Visual studio 2017 UWP?

    Hi there, I recently installed visual studio 2017 seeing GMS 2 supports it now, I setup the YYC for windows easily but was curious if anyone has been able to set it up for UWP exporting is is 2017 not yet supported for UWP?
  8. G

    Windows [SOLVED] GMS2(v2.0.6.136)/VS 2017: Can't export to Windows

    On your page http://gms.yoyogames.com/ReleaseNotes.html you write GMS2(v2.0.6.136) would be compatible with Visual Studio 2017: "Visual Studio 2017 can now be used for building Windows YYC, but you must now point to its VS_VARS.BAT file, not just the install folder" I have GMS2(v2.0.6.136)...
  9. G

    Windows Which Visual Studio path setting for Windows?

    At Preferences -> Platform Settings -> Windows -> Visual Studio path I had the path C:/Program Files (x86)/Microsoft Visual Studio 14.0 set. But with the text "Not found". I saw this video (YYC Windows Setup - YoYoCompiler :: GameMaker Studio 2 Tutorial). He installed Visual Studio...
  10. Micah_DS

    Question - IDE Having issues getting Visual Studio Community 2015 for YYC

    As the title suggests, I've been unable to get the YYC to work because I can't get VS Community 2015. It may or may not be helpful information, but I have Windows 8.1. I already did a search here on the forums and all links are outdated, and I'm not finding a solution via Google or by searching...
  11. V

    Windows FAILED to compile with Visual Studio

    Hi. I am getting a long error with no idea what happens and why. Latest GM, latest Visual Studio requirement.
  12. D

    Question - IDE [SOLVED] Is Windows YYC compiler already enabled in GMS2?

    Hello! It's just that. I'm using GMS2 and trying to test / compile a project for target Windows YYC, and I get the following compiler error message: Configuration Error : Visual Studio install not found, check your Preferences. I have installed Visual Studio 2015 (downloaded here) and there...
  13. Rozen Software

    Question - IDE Visual Studio 2017

    Hello, I tried to use new Visual Studio 2017 RC with GM2 but without success. Do you consider using this version in near future or you have already know about tricks how to successfully build a final game having only VS2017? I would not like have both 2015&2017 versions of VS on my system...
  14. S

    Question - IDE C++?

    When installing GMS2, I noticed it also came with a Visual Studio C++ package of some sort. Does this mean we can now use C++ along with/instead of GML? I didn't have a lot of time to mess around with it last night so I couldn't look into it much.
  15. T

    Legacy GM Data Structure Dumps

    Hello fellow GMC members! I am working on a dungeon crawler style game that requires a lot of data structures to store items, abilities and such. I would like to create and application using Visual C# to create DataGridView that would allow me to visually create a ds_grid. I was just wondering...
  16. W

    Windows [SOLVED] Weird compile message when starting GM S

    Hello, I'm using Gamemaker Studio EA v1.99.493, I have a weird message that appears in the compile window every time I start the program, here's the message: cmd /c ""C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\vcvarsall.bat" x86_amd64 && set ExtensionSdkDir" \Microsoft was...
  17. Zerb Games

    YYC Problems

    Upwards of 4 months ago I bought all the YYCs. I so far have only needed the Windows YYC, but it either never completes compilation even with a single object game that moves the object to the cursor, or gives me this error: I'm guessing I installed things wrong. Please tell me what I did wrong...
Top