ubuntu

  1. C

    Linux Gamepad Code Don't Works on Ubuntu

    Hi there! Sorry for my bad English and sorry for posting it again here, I posted before in the Legacy forums, but I think I posted in the wrong place. This code below runs fine on Windows, but I'm having a lot of issues to have my gamepad working on Linux with the same code: ///Checking...
  2. C

    Discussion How many of you develops for Linux?

    Hi there! I just wanted to know how many of you give support to Linux on your games? Whenever I try to look for content teaching how to develop for Linux, or ask for help about some code that isn't running well on Linux, I rarely receive some answers.
  3. J

    Wow Ubuntu 18.04 LTS is fragile..

    Not having a good day lool First Ubuntu hangs at the desktop, then power button wants to sleep in a hung state instead of power off, then OBS install through the app portal hangs at 7%. Which is my lucky number no more. This is only maybe my dozenth time using Ubuntu, but I can't help but ask...
  4. P

    Linux Error when running game from ubuntu

    after set up YYC compiler in windows i setup from windows to ubuntu laptop, when i want to run the game in ubuntu i got the next error log: ExeName= /home/pavul/Documents/GameMakerStudio2/yyc/MyGame/�j ~��8a�� MemoryManager allocated: 53775 INI DisplayName=Spacial Fight III SavePrePend...
  5. The Reverend

    Would someone please run a short test on Ubuntu for me? [solved]

    I need some help with something that might be a bug or not. Hi. I got this small test project ... https://www.dropbox.com/s/s6gi6yke3mpvl04/GLSL_test_a.yyz?dl=0 ... to test something that might be a bug on Ubuntu. However my Ubuntu Test computer is an 11 years old Laptop and I wonder if the...
  6. D

    Linux Why Linux export doesn't include linked libraries?

    Hello! I'm using the latest GMS 2 version and runtime. When exporting to Linux (Ubuntu) YYC, the generated files don't include a "run.sh" script nor a "lib" folder containing all linked libraries (which are mandatory and necessary in order to run the game on any computer). Is there a reason why...
  7. A

    Linux [Solved] Cannot Connect to Remote Ubuntu Client.

    Hello, I have started to try building my GM game in Ubuntu. The whole build prosess seems to run normally until I get this error. "WARNING: Unable to connect to remote client" And then the build ends. The folder on the target laptop does have to assets but It does not run. The Compiler is...
  8. F

    Discussion Ubuntu test not running

    Hi I'm new here so I hope I'm posting in the correct place. I'm having issues with the Ubuntu runner. I've followed this tutorial but with no luck. Every time I run the game it builds the files to the server but nothing happens afterwards. Here is what get's logged in the output panel in GM2...
  9. W

    Cursor Arrow not hiding on Linux

    Howdy, Game Maker 1.4, build working fine on Windows. On linux, the cursor Arrow do not hide, appearing over the game cursor.
  10. E

    Legacy GM Music is not playing in linux build

    I have two audio groups in my game. First (default) for the sound effects and second for music. In Windows build all is ok, but in Ubuntu i can not hear any sound file from second audio group. What's the problem here?
  11. The-any-Key

    Linux (SOLVED) Won't run on Ubuntu 14.04.5 LTS on digital ocean

    I am new to Linux and Ubuntu and I have some issues when I try run mu game on a Ubuntu 14.04.5 LTS with gnome. From GM1.4 I can compile the game. (OK) After the compile game maker put it on my Ubuntu into a folder and install it. (OK) But when I try run it nothing happens. Any ubuntu...
  12. Samuel Venable

    Linux ONLY Ubuntu 14.04 LTS?

    This applies to both GMS2 and GMS1.4 so this thread could really go under either Technical Support subforum. I noticed 2 things. 1) You can run GMS games on linux with a fresh install of Ubuntu 14.04 LTS, out of the box, with no additional depedencies installed apart from what comes with the...
  13. Samuel Venable

    Asset - Extension Borderless Window - Linux

    Description Price: $1.99 Buy now from the GameMaker Marketplace Buy now or download the demo from itch.io
  14. Samuel Venable

    Asset - Extension File Manager (for Windows, macOS, and Ubuntu)

    [Made for GameMaker Studio 2] This extension is for Windows, macOS, and Ubuntu. Manage files/folders without a sandbox; overrides GameMaker Studio 2's built-in functions. Each function that does not return a string, will return true on success, and false on failure. Functions included: real...
  15. Y

    Linux Is the export correct?

    Hello, I have GMS 1.4 and I connected to ubuntu (everything was ok) so I wanted to create an executable, for my game, (Ubuntu in this case) so I unmarked the option "Install on app" - because I wanted to install it by myself (of course). Compile was fine, but I believed it will create a " .deb...
  16. Samuel Venable

    Linux [SOLVED] How to build for Ubuntu?

    Hello community. So I bought the Desktop Edition and finally have a 64bit machine to run it on. I'm having issues building for Ubuntu however. The problem is I'm having issues connecting to Ubuntu over the network. With this info it works just fine as of GameMaker: Studio 1.4.x But in...
  17. F

    Linux Opening installer on ubuntu

    Hey guys, so I have a chromebook with ubuntu trusty 14.04 installed, and I intend to install GMS free version. Ive installed the correct version of the website, and Ive set the file, which says that its an installer, as exucatble but I dont seem to have an application that can open it...
  18. E

    Linux GM8 on Ubuntu through WINE framerate issue

    Hey there, I've been working on a 3D game in Game Maker 8.0 Pro. I recently switched my OS from Windows 10 to Ubuntu, and have been running GM through WINE. Ever since I've made this switch, I cannot get my game to run above 30 FPS, when I want it to run at 60. I've checked everything that I...
  19. K

    Linux Error message when exporting for Ubuntu

    I have tried running my game from my Windows machine to my Ubuntu machine using the green play button, which works perfectly, but when i try to create the application i get an error in the compiler: Does anyone know why and what i could try to resolve this issue?
  20. B

    Linux Required libraries [solved]

    Hi there, I'm messing around with linux publishing and went to test my game on a fresh ubuntu installation but it wont launch, does anyone know what libraries are actually needed to run the application itself? [SOLVED] Found out which ones, so far I can tell you need... libopenal1:i386...
Top