ubuntu

  1. thom

    Linux Gamepads are not working on Linux (Ubuntu)

    It appears that gamepads aren't working properly on Linux (Ubuntu). After some tests I have noticed the following: -The gamepad slot used is not in the 0-11 range, but will start at 12. -The buttons of XInput (Xbox) gamepads are also assigned wrong on Linux, for example if you press the "LT"...
  2. FrostyCat

    Linux Ubuntu Build Box for GMS 2

    Ubuntu Build Box for GameMaker Studio 2 You can now set up the Ubuntu build pipeline in GMS 2 hands-free using VirtualBox and Vagrant! Details and download available here: https://github.com/dicksonlaw583/Gms2UbuntuBox
  3. G

    Linux Ubuntu Memory Leak in Empty Project

    After a few hours of searching for a memory leak in our code, I discovered that an empty project running on Ubuntu shows a steady increase in memory use in the debugger. Memory usage constantly goes up by about 10 kb every 5 or 6 seconds. Can anybody else confirm this finding? This is on the...
  4. Goldoche

    Linux YYC on linux doesn't work?

    VM works fine for me on Windows and Ubuntu. YYC works fine for me on Windows. But I cannot run or create an executable using YYC on linux. I already have all the libraries listed here: https://help.yoyogames.com/hc/en-us/articles/235186168-Setting-Up-For-Ubuntu I have Ubuntu LTS 18.04.3...
  5. P

    Linux Cannot run in Ubuntu VM

    Hi, I cannot run my compiled game on my Oracle VM with Ubuntu 18.04.02 LTS bionic installed. I used a standard and official Ubuntu image with Gnome GUI already in it. I have added all the packages on the setup page. The game compiles just fine from my Windows PC, but it does not run on the VM...
  6. P

    Linux Ubuntu, cannot run (Xt error: Can't open display)

    Hi folks, I have compiled a game to Ubuntu on a Bananapi board. Being very new to Linux, I am having problems actually running the game. My game has two files: execute.sh and runner. When I try to run them from the desktop, I don't get an error message. I am running them from the root account...
  7. Tthecreator

    Linux Run the GMS2 IDE on Ubuntu 19.04

    GM Version: GMS2.2.2.413 (Runtime: v2.2.2.326) Target Platform: Ubuntu 19.04 (Other Linux versions may work as well) Download: N/A Links: https://dl.winehq.org/wine-builds/winehq.key https://dl.winehq.org/wine-builds/ubuntu/ disco main...
  8. DarthTenebris

    Linux Compiling Game Maker Studio 2 Projects on Linux

    Hello everybody, I have managed to install and run Game Maker Studio 2.2.1.375 with Runtime 2.2.1.291 on Ubuntu 19.04 with the help of Wine 4.0, however when I tried to compile for Ubuntu it couldn't recognize the host machine, and when I tried to compile for Windows, it didn't like it either...
  9. P

    GML Joystick (Windows and Ubuntu)

    Hiya. I'm trying to get a simple arcade joystick with a few buttons working in a game. I first need it in Windows and later preferably exported to Ubuntu. Windows detecs the joystick just fine and I can trace on a test website. I've been trying to use joystick_xpos() to trace my joystick in...
  10. Martin Linklater

    Linux build runs twice as fast as Windows

    I have my game set to run at 60 FPS and this works fine on Windows. When I build the game for Ubuntu it runs really fast... I'm guessing twice as fast. I've looked all over the options and can't seem to fix this. Can anyone tell me what I'm doing wrong ? Thanks.
  11. P

    Linux Ubuntu build with virtual machine, cannot connect

    Hi. My aim is to compile to Linux using Ubuntu on a virtual machine. My ultimate goal is to use GameMaker to create arcade style games and run them on a banana pi board, so I can develop and build arcade machinces as a project with my high school students. I'm new to virtual machines and...
  12. RobotoSkunk

    Linux Wrong executable format (Ubuntu)

    Hi, I'm trying to run my game on Ubuntu 14.4 using VirtualBox to emulate an Ubuntu computer. This problem did not happen to me in Game Maker Studio and it started happening to me when I switched to Game Maker Studio 2 Can someone please help me with my problem? The error that appears in the...
  13. NNNIKKI

    Windows Converting my game to other platforms

    I'm making a game in GMS2 on a WIndows 10. Is there a way to also convert it to Mac or Linux? I tried changing it in the top-right corner but it tells me to plug in my Mac, which I don't have. Can I convert to Mac without owning a Mac? I've seen other game engines be able to do this.
  14. A

    Linux Can't build on ubuntu in YYC mode

    Hi, I am having difficulties testing on Ubuntu, I have my Windows machine (with GMS2) and my laptop running Linux Mint 19 (which is based on Ubuntu 18.04) They both on the same network and the ssh connection is successful. When running on VM mode, it compiles well and runs on the laptop...
  15. FredFredrickson

    Linux Game name shows as "Unknown" on Ubuntu Activities bar

    When I run (or run a compiled version of) my game on Linux, it shows the correct icon, but the name on the Activities bar at the top of the screen just says "Unknown". The correct name shows up on the window name at the top of the window, however. I'm using GameMaker Studio 2 (the most...
  16. K3llyll

    Linux [MAYBE SOLVED]• How can I use .SO files ?

    Actually there are a few questions that I want to ask. EDIT : I got the answer to the first two questions in another forum. I just need help with the third question. 1• I don't know much about Linux. .so files on Linux = .dll files on Windows, is it correct ? I mean, does both types of files...
  17. B

    Linux Keyboard controls don't work in Linux build

    Linux users playing my game DASH can't press two buttons at the same time? It's a platformer (so you press several keys at the same time all the time) and there is no way I am redesigning the controls and mechanics because of this. All my keyboard check code is simply standard gml. Nothing...
  18. chaslinux

    Windows Fasteroids

    Fasteroids is my first foray into GameMaker. Inspired by the original Atari version of Asteroids and owing it's current state to a very long list of people in (and out of the GameMaker community). This is the first release I'm willing to share (though it has a long way to go still). Get the...
  19. chaslinux

    Linux [Solved] GMS 1.4.x Compiling to Ubuntu Failed - bits/c++config.h not found on Ubuntu 18.04.1

    I followed the guide for setting up Ubuntu here: https://www.yoyogames.com/blog/107/how-to-compile-to-linux-ubuntu I also did the steps for setting up Ubuntu 16.04 for GMS 2.x (I'm using 1.4.x). My desktop system however is running the slightly newer Ubuntu 18.04. When I installed the software...
  20. NeZvers

    Legacy GM Compiling to Ubuntu Errors

    Running test compiles and runs the game, although PixelPope palette swap morphs character and button remapping acts weird as Joysitick 1 is continuously pressing pov left, although I have xbox 360 controller plugged in and passed to virtualbox. But creating an application without YYC I get...
Top