ubuntu (linux)

  1. O

    SOLVED Missing executable after building on Raspberry Pi

    Hi, I just upgraded to v2.3.2.420 and rebuilt my Raspberry Pi projects. I can't seem to find any executable output though. Previously I would build the project (Ubuntu->Local->YYC->pi->Default) and the executable would appear in: /home/pi//GameMakerStudio2/yyc/ProjectName/ProjectName Where...
  2. Diegovz01

    Linux [SOLVED] I'm totally noob at linux but want to try ubuntu export. I simply can't connect.

    Hi, I just installed ubuntu as dual boot on a laptop and followed the instructions from the ubuntu guide to make the connection with a windows 10 desktop and GameMaker Studio 2 v.2.3.1.542. Installed all the dependencies and configured the target settings fields on GMS2 but when I press the...
  3. EvanSki

    GMS 2.3+ Setting up Raspberry Pi Export for Game Maker Studio 2.3.1+

    GM Version: 2.3.1+ Target Platform: ALL Links: Link to DragoniteSpam's video which helped start this tutorial Summary: In this tutorial, I will show you how to setup, use, and export to the Raspberry Pi using Game Maker Studio 2.3.1 There is 3 Steps total and an optional 4th step NOTE: Don't...
  4. tylerbertz

    GMS2 file handling on Ubuntu

    do the file handling function [ directory_exists(), directroy_create() ..] Work on Ubuntu? if so were is the working_directory located? and possable get a simple example of createing a directory "apples" So far I have: Create Event: Step = 0; Step Event: if(Step == 0){...
  5. EvanSki

    Linux WOW Linux doesnt compile! Please Help!

    Im running on a Raspberry Pi 4, Ubuntu Desktop 20.10 64-bit I've followed this https://help.yoyogames.com/hc/en-us/articles/235186168 YYC I get bash: /Linux_sample_project: No such file or directory VM I get bash: /Linux_sample_project: Exec format error Create Executable works but I can...
  6. T

    Steam Steam version Gamemaker:studio 2 can't use mouse on Ubuntu

    I tried installing gamemaker studio 2 in steam on Ubuntu, but the mouse doesn't work at all. The keyboard is able to work and the mouse can't click the buttons so i can't use it. Can someone help me?
  7. dyh

    Linux Ubuntu Release - Game works, Achievements work, but Steam Play button doesn't

    Hello everyone Somehow I managed to get my game running from my PC in the Ubuntu 18.04.2 Virtual Machine ( You can see how I did it in my last thread ). The achievements are also activating while I'm connected to my Steam account through the app. However I can only open the game by running the...
  8. dyh

    Linux Ubuntu export - steam achievements not working

    Hello everyone So I just released my game on steam for Windows PC and it works ( Game + achievements both work ). I try now to export it for Ubuntu. When I run it in Game maker for windows through a Linux Virtual Machine all works as well ( Game + achievements ). BUT when I export it there...
  9. Z

    Windows Can't Properly Deploy Gamemaker Studio 1.4 Game From Windows To Linux

    Hi, I'm trying to deploy a game to Ubuntu (Linux) using Gamemaker Studio 1.4 in Windows and I'm missing some libraries. I'm using Windows 10 to deploy to Ubuntu Studio 20.04. I've installed the libraries listed on this website, except I'm using lib32ncurses6 instead of lib32ncurses5 and...
Top