troubleshoot

  1. S

    Mac OSX MacOS GMS2 shows only grey screen when running/previewing the game

    Hi guys, So today I updated GMS2 to the most recent version on MacOS, however I noticed that now whenever I try to run the game I get nothing but a grey screen (I attached a screenshot in this post). I then went to some of my other earlier GMS2 projects that I know used to run properly, but...
  2. B

    Legacy GM error when compiling game

    Hello, my game no longer compiles and launches so I can test it, anyone know what is wrong? this is what the compiler outputs
  3. T

    Windows 'Steam Enabled' Not working

    Hey Everyone I've implemented the Steam SDK, and written in what I think is the proper AppID but when I run the game two things happen. Running the game in Gamemaker runs it fine, but the steam overlay does not appear. Running a .zip version of the game does absolutely nothing. The game does...
  4. T

    GMS 2 Displaying Text on Multiple Screens

    Hello, I am currently going through the tutorials of GMS 2 and I believe I've gotten through all the videos of the basic top-down shooter game. I wanted to complete it myself, and I'm having trouble with something. I have a gameover screen and I want to display the final score, but when I try to...
  5. T

    Windows GameMaker Studio 2 Crashes on Startup

    Hello, Yesterday GameMaker Studio 2 worked perfectly fine. Today I got the Windows creator update and now when I open the program, there is a white screen and then it crashes. I have tried uninstalling and installing GameMaker Studio 2 multiple times, through Steam and through the regular...
  6. D

    Question.

    Hello all first of I am a relatively new to Game Maker and I am picking it up pretty quickly. I am also new to this forum so thank you guys for having me! If this is posted in the wrong forum please let me know! As for my question: So I am making a plat former game. In this game you can collect...
  7. G

    Legacy GM Player Character is no longer moving

    I have been working on a basic platformer currently and just finally got the animation to play properly when the keys are pressed, but now my character won't while on the ground. It will jump, and i can move forward that way but as soon as it lands it will no longer move on the x-axis. Here is...
  8. A

    Problem Importing 8.1 to Studio [solved]

    I've got a game that I need to use Studio features on, but when I imported it, and tried to hit Run, I got an error message: The given key was not present in the dictionary. Here's the compile console: Compile started: 12:46:12 PM...
Top