steam

  1. Victorian_Clambake

    Steam [SOLVED] After updating to 1.4.1772 my application won't launch on Mac

    [SOLVED] The trickiest part about this will be that I don't have the problem, only my users and friends. I released my game "The Caribbean Sail" onto Steam a couple days ago and all went well but achievements weren't working for Linux and the only good solution was to update my Game Maker...
  2. Y

    Discussion Question About Licenses

    Hello, I am planning on developing for Steam, Android, and IOS. Will I need to buy the $100 desktop and $400 mobile licenses or just the $400 mobile one? Also, would I be able to buy the cheaper desktop one for now and upgrade later?
  3. 2

    Steam 2 Questions on Saving for a Steam PC Game

    Two Save Questions 1. Does the basic save system ( game_save() ) work for a Steam PC game? 2. What is the best type of save system for a Steam PC game (ini, txt, ds_map_secure_save, ect)?
  4. L

    Linux UGC items cannot be loaded on Linux

    Hi, I'm one of the developers por Relic Hunters Zero. We are adding mods support for the game through steam workshop, using GMS 2. On windows and mac it is ok, but on linux, even though steam_ugc_get_item_install_info gives the folder for the installed item, a call to file_exists always sayas...
  5. M

    Question - Code GMS2 with SteamSDK

    Hi guys, is there any tutorial on how to use steam functions in Game Maker Studio 2? Ty, regards.
  6. C

    Mac OSX App On Steam Only Works For Me?

    Trying to get my macOS app (built with Game Maker 1.4) on Steam. I can compile and run it on my Mac. I can send it to friends and they can run it fine. When I enable Steam capabilities, it still runs fine on my machine, but if I upload it to Steam and others download it, the window just closes...
  7. C

    Mac OSX App On Steam Only Works For Me?

    I gave some Steam keys to some friends to test my game out. The PC version works fine, but when they download and run it, they get this bit of info. View in Interface Builder file, creating generic Window instead 2017-08-15 11:51:49.760 CircuitDude[32300:1253261] NSWindow does not support...
  8. Y

    Question - IDE [SOLVED] Steam build error

    Hey guys. I am trying to create a build with Steam enabled. But it tells me that Failed to copy Steam DLL - 'D:\steamworks\redistributable_bin\steam_api.dll' - SDK not installed properly? Steam SDK version: 1.35a GMS 2: IDE v2.0.7.171 Steam Runtime 2.0.7.110 OS: Windows 7 x64 The dll itself...
  9. S

    Steam "Meta Star" Coming Soon on Steam! (8/23)

    Steam Link Have you ever been playing a game and wondered, WHY IS THERE NO HORSE ARMOR or THIS LEVEL NEEDS MORE MATH!? Well, Meta Star is your answer!!! Race the rest of the internet to beat the game, and the winners get to tell the developers what to include in the next update! And oh yea...
  10. N

    Legacy GM Steam Support

    Hello, I'm new on this community and I bought GameMaker Studio Pro 1.14 on HumbleBundle today. I already activated my key on YoYo's page, all good. The question that I have is can I request a key for Steam? I readed some comments that you can request one in 2 weeks after the key is activated on...
  11. W

    Creating app for steam?

    Is there any tutorial how to add my game on steam.... for idiots like me ;)
  12. Pfap

    Steam Batch file problem

    Hello, When I run the batch file to upload to Steam I get this error: Assertion Failed: !m_bHaveLoginkey Has anyone else dealt with this?
  13. Tommah

    GML How to implement Steam Workshop

    This is not about uploading to GM: Studio's workshop. I have a game on Steam and am trying to implement workshop with that game for custom levels/maps. I have the game saving and loading everything just fine, but when I go to upload to our Workshop it gives me an Error and creates an entry in...
  14. S

    Windows Intrusion Protocol, the brutally difficult retro platformer, is now on Steam

    Hello, everyone! We are Somber Dawn Studios, and yesterday we released our first Gamemaker game on Steam after 7-8 months of development. It's a brutally difficult 10-level retro platformer called Intrusion Protocol. Check it out and let us know what you think! Click here to get it on Steam...
  15. A

    Steam Interactive Comic - All You Can Eat

    It's out on Steam NOW: http://store.steampowered.com/app/663240/All_You_Can_Eat/ Story Take control of a modern hero of our times, a man so lazy he decided to quit his job and just spend his life inside an All-you-can-eat diner. As years go by, his freeloading nature becomes legend, but...
  16. JAG

    Mac OSX GMS2 splash screen

    Hiya, Im wondering if anyone knows if/how I can get rid of the GMS2 splash screen when I launch my game. Im on the MacOS beta, but I've paid for GMS2 via Steam.
  17. CKlidify

    Steam Workshop uploads not working?

    I'm trying to upload things to my game's workshop but it's not seeming to work. On the left pressed event I have this: var app_id = steam_get_app_id(); title = get_string("Title",""); map_save(title + "/map.ssm"); screen_save(title + "/thumb.png") desc = get_string("Description",""); new_item...
  18. CKlidify

    Question - Code Adding a file to Steam Workshop

    I'm trying to make it so I can upload files to steam workshop and I'm using this code to test it: new_map = steam_ugc_create_item(steam_get_app_id(), ugc_filetype_community); var title = get_string("Title",""); steam_ugc_set_item_title(new_map, title); var desc =...
  19. MrDave

    Steam Getting the Steam Controller to work in GameMaker

    GM Version: 1.4 Target Platform: Windows Download: Gamepad tester gmz Links: Guide can be found here It doesn’t matter if you own a Steam Controller or not, I will try to explain everything as I go along, however if you are putting gamepad support in I would highly recommend that you at least...
  20. G

    Question - IDE GMS2 still "running" on Steam after it's closed

    As the title says, whenever I want to restart GMS2 (I'm using the Steam version) I can't just close it and then start again. It keeps saying "Running" next to the "GameMaker Studio 2 Desktop" in Steam and it won't allow me launch saying that I already have one copy launched (which I don't)...
Top