raspberry pi

  1. O

    SOLVED Missing executable after building on Raspberry Pi

    Hi, I just upgraded to v2.3.2.420 and rebuilt my Raspberry Pi projects. I can't seem to find any executable output though. Previously I would build the project (Ubuntu->Local->YYC->pi->Default) and the executable would appear in: /home/pi//GameMakerStudio2/yyc/ProjectName/ProjectName Where...
  2. O

    Gamepad on Raspberry Pi won't register A and B buttons.

    I'm trying to get one of the generic USB gamepads (Buffalo, Kiwitata, etc) to work on the Raspberry Pi. The DPad works if you treat it as an analog stick and the X and Y buttons register along with the shoulder buttons. The problem is the A and B buttons don't register at all. They work fine...
  3. EvanSki

    GMS 2.3+ Setting up Raspberry Pi Export for Game Maker Studio 2.3.1+

    GM Version: 2.3.1+ Target Platform: ALL Links: Link to DragoniteSpam's video which helped start this tutorial Summary: In this tutorial, I will show you how to setup, use, and export to the Raspberry Pi using Game Maker Studio 2.3.1 There is 3 Steps total and an optional 4th step NOTE: Don't...
  4. S

    Linux Raspberry Gamepad (detecting too many)

    Hi! I'm doing some test-compilation on a Raspberry Pi 4 and Gamemaker. Everything works fine except that when I run my game it detects all devices that are attached through USB on the Pi as gamepads. I am adding a player object for every "gamepad detected" in Async-System as described here...
  5. EvanSki

    Linux WOW Linux doesnt compile! Please Help!

    Im running on a Raspberry Pi 4, Ubuntu Desktop 20.10 64-bit I've followed this https://help.yoyogames.com/hc/en-us/articles/235186168 YYC I get bash: /Linux_sample_project: No such file or directory VM I get bash: /Linux_sample_project: Exec format error Create Executable works but I can...
  6. 2play!

    Pi4 Debian 10 Buster: GameMaker games Error "CURL_OPENSSL_3"

    Hi to all, At a point there was with the GMS help a scriptmodule to add 3 games to pi ports section. On Debian Stretch games and script run fine as it uses the libcurl3 Not the case with Pi4 that no OS upped to Debian Buster. It is using libcurl4 When you ran any of the games your get this...
  7. L

    UWP Can UWP export run on Win 10 ARM on Raspberry Pi ?

    Since Win 1o ARM Rpi offers native support on ARM32 and ARM64 and emulation for x86, goes UMP export run properly on RPi ? Just asking before I spend money on UWP export. Any help is appreciated. Thanks in advance.
  8. P

    Linux Ubuntu, cannot run (Xt error: Can't open display)

    Hi folks, I have compiled a game to Ubuntu on a Bananapi board. Being very new to Linux, I am having problems actually running the game. My game has two files: execute.sh and runner. When I try to run them from the desktop, I don't get an error message. I am running them from the root account...
  9. N

    Game Maker 8.1 - Raspberry Pi, Compiling with Linux

    I was wondering if you are able to compile Game Maker 8.1 Games for Linux?
  10. G

    What´s up with Raspberry Pi?

    Some people have been complaining about the lack of exportability to Raspberry Pi, as I understood, one of the problems for its compatibility is that uses an ARM processor (so its architecture is not compatible). I was thinking and researching and I found out that smartphones also use ARM...
  11. S

    Legacy GM Can you export to Lunix, in order to publish and play a game on a Raspberry Pi?

    I'm working on a Raspberry Pi computer for Robotics, that runs of Raspbian, NOOBS, and Retro Pie. Is there a way I could make a game that runs on the Raspberry Pi? I've seen that it's possible.
Top