parsing

  1. If Programable_Matter

    Error when working with JSON

    I've been uploading json files unto a webserver and had no problem with them on game maker... for some reason I now keep getting this error with a new project I have started : json_decode argument 1 incorrect type (undefined) expecting a Number (YYGR) Create Event http_get("website.json")...
  2. M

    Android Error parsing

    Hi. It has been a while since I updated the gm2. Today I update it and I get an error when compiling (image attached). In the line that marks me error is the "if" number 250 of the object or the "switch (xx)" number 250 of the object. Can anybody help me? Regards, Mataca
  3. D

    SOLVED Compile error on IOS, xcodebuild error, CFPropertyListCreateFromXMLData, Old-style plist parser

    Hey fellow Game Makers! I can't compile to IOS right now, as I'm trying to test my game on an iphone. It works fine and compiles to the MAC but not the iphone. GMS: 1.4.1804 Mac OS: Sierra High 10.13.4 xcode: 9.3 (9E145) Command line tools (macos 10.13) for xcode 9.3 Compile 2018-04-01...
  4. CedSharp

    GML [SOLVED]: Parsing Strings ignoring substring

    So I don't want to create a book out of my problem, here it is: I have a string, say 'Hello [c:yello]friend[c:default]! How are you?'. That string has tags (starts with [ and ends with ]) inside of it for colors. Now, I'm trying to make a draw_text_ext that ignores said tags, but manually...
  5. 2

    GML Loop Draw Word Wrapped Text in Box, Dealing with Spaces

    I need to make a textbox that loops through each letter, and word wraps a message that could be longer than a single text box even when broke into multiple lines. It needs to break spaces properly when they get near the end of the horizontal line space in the textbox. It also needs to clear the...
  6. T

    Get_char_at() parser not finding special characters despite being UTF-8

    I'm loading a CSV using buffer_load(), then going through it character by character with string_char_at(), it doesn't return any characters like 开始, スタート, 시작, Начать despite the .csv being encoded in UTF-8. This used to work but now it doesn't. Any ideas? I'm on v7.7.1447. Here, buffer_load()...
Top