linux

  1. B

    What to expect before purchasing gms 2?

    Hello everyone. Completely new here and was just a little curious about the engine you guys use. I'm thinking about buying a license but have a few concerns. The 100 dollar license(something I can afford) says I can export to Windows, Mac, Linux. I also plan on using...
  2. thom

    Linux Gamepads are not working on Linux (Ubuntu)

    It appears that gamepads aren't working properly on Linux (Ubuntu). After some tests I have noticed the following: -The gamepad slot used is not in the 0-11 range, but will start at 12. -The buttons of XInput (Xbox) gamepads are also assigned wrong on Linux, for example if you press the "LT"...
  3. FrostyCat

    Linux Ubuntu Build Box for GMS 2

    Ubuntu Build Box for GameMaker Studio 2 You can now set up the Ubuntu build pipeline in GMS 2 hands-free using VirtualBox and Vagrant! Details and download available here: https://github.com/dicksonlaw583/Gms2UbuntuBox
  4. fireday2

    GMS2 and steam Proton

    Hello all There is steam Proton. Which give possibility to run MS Windows software on Linux. Proton is based on wine. And the Proton already included in steam, you just enable it and then you can run the windows games/soft on your linux. But there is a problem - not all soft can be launched and...
  5. Dwighty4000

    GMS 2 how hard is it to puslih a game for linux to?

    I'm currently making a game that should come out for windows, but how complicated would it be to publish the same game for Linux and Mac with GameMaker Studio 2? In this case, would it be just a question of pressing a few buttons to export the same game made to the other platforms, or is that a...
  6. DarthTenebris

    Linux Export to AppImage Option

    Hello everybody, I recently started to tinker around with the Ubuntu export option, and noticed it only exports .zip files. Is there any way I can convert it into a single .AppImage package, similar to the single executable .exe export option from GMS1.4? Thank you for your time.
  7. Japster

    Linux Linux build failure (PSCP/SCP command) using YYC build?

    Hi guys! - Finally got a Linux box set up, configured, and able to build my games for Linux! They build fine using VM! - it's cool to see them running on Linux, ready for adding to Steam.... ...BUT... ...when I select YYC as the build method, the Linux build fails with the following:- ...
  8. Zuurix

    Linux Game doesn't launch when uploaded to Steam, needs libraries [Solved]

    Hey, can someone GameMaker + Linux + Steamworks savvy help me figure out what to do? I'm trying to upload Linux build and it's not going well, supposedly Steam uses "outdated libraries", whatever that means... I use Xubuntu virtual machine, created following a guide, and the game seems to work...
  9. Goldoche

    Linux YYC on linux doesn't work?

    VM works fine for me on Windows and Ubuntu. YYC works fine for me on Windows. But I cannot run or create an executable using YYC on linux. I already have all the libraries listed here: https://help.yoyogames.com/hc/en-us/articles/235186168-Setting-Up-For-Ubuntu I have Ubuntu LTS 18.04.3...
  10. Goldoche

    Shaders [Solved] A shader works fine on windows but not on linux?

    I'm using a very simple shader for my game which displays a sprite pure white. shader.vsh: attribute vec3 in_Position; // (x,y,z) attribute vec4 in_Colour; // (r,g,b,a) attribute vec2 in_TextureCoord; // (u,v) varying vec2 v_vTexcoord; varying...
  11. D

    Windows WSL (Windows Subsystem for Linux) setup

    Is it possible to generate versions (YYC or VM) for linux using Windows Subsystem for Linux (WSL)?
  12. Samuel Venable

    [SOLVED] [Linux/X11 extension] would this ever cause an infinitie loop?

    Code is pulled from another thread of mine: /****************************************************************************** MIT License Copyright © 2019 Samuel Venable Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated...
  13. P

    Linux Cannot run in Ubuntu VM

    Hi, I cannot run my compiled game on my Oracle VM with Ubuntu 18.04.02 LTS bionic installed. I used a standard and official Ubuntu image with Gnome GUI already in it. I have added all the packages on the setup page. The game compiles just fine from my Windows PC, but it does not run on the VM...
  14. P

    Linux Ubuntu, cannot run (Xt error: Can't open display)

    Hi folks, I have compiled a game to Ubuntu on a Bananapi board. Being very new to Linux, I am having problems actually running the game. My game has two files: execute.sh and runner. When I try to run them from the desktop, I don't get an error message. I am running them from the root account...
  15. DarthTenebris

    Linux Compiling Game Maker Studio 2 Projects on Linux

    Hello everybody, I have managed to install and run Game Maker Studio 2.2.1.375 with Runtime 2.2.1.291 on Ubuntu 19.04 with the help of Wine 4.0, however when I tried to compile for Ubuntu it couldn't recognize the host machine, and when I tried to compile for Windows, it didn't like it either...
  16. P

    Linux Ubuntu build with virtual machine, cannot connect

    Hi. My aim is to compile to Linux using Ubuntu on a virtual machine. My ultimate goal is to use GameMaker to create arcade style games and run them on a banana pi board, so I can develop and build arcade machinces as a project with my high school students. I'm new to virtual machines and...
  17. jeff300

    Linux Gamepads on Linux

    Has anybody gotten a GMS game to successfully work with a gamepad on Linux? I have made multiple games that all work fine with gamepads on Mac, Windows and iOS. They will not work with any gamepad on Linux. I followed the documentation and have the recommended 3rd party gamepad libraries...
  18. Ronald Wendt

    Free Klomanager - Regurgitated 0.70 Alpha

    Hello fellow developers, this is my first post here and i wanted to present you my latest game project. Its the remake of a silly economic simulation dealing with toilets (toilet = Klo in German) that was first done in 1994 for the Atari ST and then moved to the PC in 2000. This time its aimed...
  19. CleanWater

    Linux gp_axislv returning only 0

    Hi there! The gp_axislv is returning only 0 on Linux (using D-Input controllers). Is there any workaround for this? My whole game pad system is functioning perfectly on both Windows and Linux. I only need to fix this single issue to release a new update for my games. On Windows the values...
  20. FredFredrickson

    Linux Game name shows as "Unknown" on Ubuntu Activities bar

    When I run (or run a compiled version of) my game on Linux, it shows the correct icon, but the name on the Activities bar at the top of the screen just says "Unknown". The correct name shows up on the window name at the top of the window, however. I'm using GameMaker Studio 2 (the most...
Top