libpng

  1. N

    Legacy GM How -Exactly- do you update LIBPNG?

    The title says it all, since GMS is no longer being updated, and their LIBPNG in the newest release appears to be 4 years old I'm looking to update it, because my program needs this else in reality it simply wont function. So I've got the newest version and updating isnt an option and down...
  2. C

    libpng library security vulnerability

    Hello My name is Constant from the Netherlands and I am using GameMaker Studio v1.4.1675 (r40508). I work on a Windows 7 pc 64-bit. I created an app and I choose "Create Application" for "Android". The .apk has been created correctly and the it works fine when I run it on my tablet or...
  3. unpaid-thief

    libpng eeror google play(i try to fix 6 month!)

    hi...please give me a very easy way to fix this nightmare libpng error...i realy sad i try to fix libpng for publish in google play then i update game maker to 1.4.1760 but i cant create apk file with this version my previuse version is 1.4.1657 and create apk but new version i try it 6 month...
  4. D

    Play store Rejected my Game

    They said i have to update my libpng.... im using game maker 1.4.1763. please let me know how to fix this issue
  5. G

    How to include newest libpng as an extension?

    Months ago I got the message from Google Play that the used libpng in my app is a security hole and I should fix it and new apps can only be uploaded with a fixed version of libpng. 1) My current version of GameMaker:Studio is v1.4.1763 (r41504). Is the libpng security hole closed there? 2)...
  6. RizbIT

    libpng issue and early re;ease

    i need to publish some apps but now cant as past 17th sept and gm still not fixed the libpng issue. google blocks all new gm apps. i heard about early release version where this issue is fixed but how do you get this, i dont want to fraff about with different versions as ive spent too much time...
  7. SnoutUp

    Android Is there a way to update libpng without upgrading GameMaker?

    This is a long shot, but my question is pretty straightforward - can we get a standalone libpng patch for older GameMaker versions (I'm using 1.4.1757 now) or maybe instructions how to update it ourselves if that's even possible? Context for devs, who are not working with Android games: a...
  8. M

    libpng before 17 september?

    Hi. I want to know if libpng fix update will be before of 17 september for Game Maker Studio. I know that this was fixed in Early Access, but I dont use Early Access, I use just Game Maker Studio with Android Export Module. Regards, Mataca
  9. R

    Android GameMaker: Studio Issues with Android

    If no changes by Sept 17th the following will occur: LIBPNG ISSUE: Beginning September 17, 2016, Google Play will block publishing of any new apps or updates that use vulnerable versions of libpng. ADMOB ISSUE: In order to ensure that your ads continue to serve after September 15th, 2016...
  10. P

    libpng Error

    Should I be concerned about this or is it something on the game maker developers part? If so, sorry about the post and hopefully, we will have an update soon. Thank's!
  11. R

    Android ADmob LibPNG timeline

    Wondering if the new update will have fixes for both the Admob and LibPNG issues. I'm hoping they push the two together before the September 15th-17th, 2016 deadlines. Thanks to anyone who knows.
  12. A

    Google Play problem with libpng

    Hello. I've got this problem in my developer console: "Your application uses a version of libpng, which has a vulnerability. For more information and the date by which you must remove this gap, see this article in the Help Center. Applies to APK version 1000031." , but I don't know, how to...
  13. F

    LIBPNG

    Any new news on this issue? In case you aren't aware, here's the message from Google: We detected that your app(s) listed at the end of this email are using an unsafe version of the libpng library. Apps with vulnerabilities like this can expose users to risk of compromise and may be considered...
  14. camerakid

    Android GooglePlay libpng

    Hey Everyone, Good to see GMC is back! :-D Got the following message on GooglePlay developer console. "Action required: Migrate your app(s) to use libpng v1.0.66, v.1.2.56, v.1.4.19, v1.5.26" Is it a Game Maker: Studio related problem or is it possible to change the libpng in a different...
Top