ide bug

  1. M

    GMS 2.3+ Keyboard shortcuts stop working after update v.2.3.2

    Yesterday I updated both IDE and Runtime to v 2.3.2 and started to experience troubles with the keyboard shortcuts. They all just stop working after sometime when I'm working on my project. I didn’t find exact STR but it seems it's somehow related to using P key in the room editor (it doesn’t...
  2. C

    GMS 2.3+ Gamemaker run out of memery while in debug mode

    Hi. I am using GMS2 with IDE v2.3.1.542 Runtime v2.3.1.409. (Windows 10) The problem is when I running my game with debug mode, add some break point, and if I move my mouse to some local variable. for example a struct called 'node'. Then the IDE will have no respond and crash. But my game is...
  3. C

    GMS 2.3+ Object event script got deleted when delete some other script file.

    I am using GMS2 with IDE v2.3.1542 Runtime v2.3.1.409. The problem is when I delete some unwanted scripts in IDE, some of my object event scripts will be "deleted" too. All the code wrote in those object event will disappear. I also tried some method like export - reimport. But none of them...
  4. TheRudolfGaming

    SOLVED Auto-fill showing duplicate suggestions of variables/functions.

    Heya! As the title implies, after updating to 2.3.1 today and starting to modify my code, I noticed that my auto-fill suggestions were getting shown multiple times I can assume this could be a bug/glitch of the new update/conversion to the new version, cause this behavior was not documented...
  5. Marko03970

    SOLVED IDE crashing for some projects

    Hello, I have a problem with Game Maker Studio 2.3+ IDE. I used to work on a project for a long time (since Game Maker Studio 1.x) and I didn't get this problem before. Everything was working well, but then, when I tried to compile the game, in the output window I got this message "Process is...
  6. N

    GMS 2.3+ GMS 2.3 Not Generating Sprite Collision Masks

    Newly created sprites in GMS 2.3 don't have their collision masks generated. Automatic and Full Image modes do absolutely nothing, and masks can only be set and resized manually. Otherwise, mask coordinates stay at 0,0,0,0, as shown in the image below. Mask type has no effect either. I've tried...
  7. N

    GMS 2.3+ Projects from Beta won't save

    I participated in the 2.3 Beta, and was working on a project during it's development (Yes, I know I should've considered not using the beta version of the IDE for a project, but still). When I ported over the project to the full release of 2.3, the first thing I noticed was that none of my...
  8. C

    Mac OSX 2.3 Update Causes Very High CPU Usage

    Since updating to 2.3, I have noticed extremely high CPU usage for both the IDE and the YoYo Runner. I have tested using empty projects, and have found that the IDE sits at over 40% CPU when the laptop is unplugged (according to Activity Monitor), and when plugging in a power cable, the number...
  9. S

    Steam Bug, mouse will stop working when leaving and entering GMS2 until i right-click somewhere

    Also. for some reason when i do right click and return to GMS2, it will write out "r f" where ever my cursor is situated. I have no idea, and this sounds so bizzare, so i tried recording it. This only started happening recently. But i haven't gone into any beta modes. And i've tried...
  10. Catalystl

    Question - IDE [RESOLVED] Game Maker stops responding when I add sounds

    I was about to import a sound file into Game Maker, but as soon as I clicked on the 3 dots button, Game Maker stopped responding. I restarted Game Maker twice and got the same result.
  11. Cpaz

    Windows 144hz monitor issue?

    I seem to have a consistent issue where if the GMS2 IDE or my game is running on a 144hz monitor, it locks itself to a lower framerate. Moving it over to my 60hz monitor smooths the framerate back to normal. I've tried searching this separately, and the consensus I read was it locks to 50 fps...
  12. B

    Question - IDE IDE timing out when loading

    So I've got a weird problem that I can't seem to find a solution for. I've tried googling it, but I guess I'm not quite sure how to phrase it. This problem just happened out of no where one day. I tried opening up GameMaker, and while it was loading up, the little start screen just froze on the...
  13. S

    Question - IDE High CPU Usage? Constant high cpu while idling.

    My GMS2 has always crashed once in awhile but now it's getting more often and it's beginning to bother me. I checked my task manager and GMS2 is always at 50% - 80% CPU usage even when it's doing absolutely nothing in the IDE. Anyone know how to fix this?
  14. V

    Windows Bug: Tile layers with offset not rendering all tiles in IDE

    If you create a tile layer and give it a negative vertical offset (ex: -12 y offset), the expected behavior is that the tile grid visible on the IDE will show a little higher, but you should still be able to paint tiles and see those tiles in every cell of the tile map grid shown while in IDE...
  15. N

    Question - IDE GML doesn't recognize the colours set in 'Variable Definitions'

    Seemingly, the colours you pick in an object's Variable Definitions in the IDE (also called Object Variables - very confusing), are not actually valid colours in GML. The colour picker creates a HEX-colour in the format #RRGGBBAA, while GML expects either a color made through make_color() or...
  16. Ggd07

    Question - IDE Sorting resources is painful and wastes a lot of time. Is it just me?

    Hello there, I bought GameMaker Studio 2 Desktop last year but haven't used it until now, since we decided to invest in the mobile module. I am trying to sort my resources and it seems the IDE does not allow me to, and constantly notifies me of "changed files" while I do that. I wanted to ask...
  17. baconandgames

    Question - IDE Amazon Fire Trial causing UserLogin_ExpiredDetail

    I'm getting the following error when I try to log in: UserLogin_ExpiredDetail I own a permanent license to GameMaker Studio 2 and also the Mobile export plugin. Curiously, I noticed that the Amazon Fire Trial, that I had added to my account a while back, expires today (1/27/18). This is the...
  18. S

    Question - IDE BUG in Code Editor

    A small but unpleasant bug, due to which the code is lost. Try to repeat Open the first script in new IDE windiow. Editing the text of this script. Drag one more script into the same window onto the new tab. Let's edit the second script. Close the window. Open the second script in new window...
  19. T

    Question - IDE GMS 2 won't connect to Mac or Ubuntu

    I'm trying to connect my Mac and Linux computers to GMS 2, but it keeps failing. For the Mac it manage to connect then it failed to connect after trying to build a game. I tried to see if it was my computer so I used Putty and I was able to connect to both of my computers. Then I tried using GMS...
  20. A

    Question - IDE IDE Mouse Snapping

    I'm not certain if this is a bug or a feature that I haven't been able to turn off. Whenever I bring the IDE into focus and then click outside of the IDE (eg. on another window) my mouse cursor is snapped back within the bounds of the IDE. This happens every time I try to deselect the IDE. Is...
Top