error

  1. E

    Android Google play services

    Hi, I have created an application several times and tested it on my mobile phone. When I install Google Play, it always throws out errors. I no longer know how to solve this problem. I will be grateful for any advice. Google Play services don't work with version 2.3?
  2. WanSou

    GML How To Properly Disconnect A GML Client From A Node.JS Server

    Hey, i am trying to disconnect a gml client from a node.js server but whenever i try to disconnect it by using "network_destroy()" the node.js server crashes and returns " Error: read ECONNRESET " Which from my research is because the connection was abruptly disconnected so... how do i...
  3. J

    GMS 2 (DnD) DoConv :1: illegal undefined/null use

    I'm pretty new to game design, and programming specifically, so I'm hoping these types of problems will make more sense to me as time goes on. As of today, all the scripting and "argument" and "target" stuff feels a little more familiar, but it all gets me jumbled up if something doesn't go...
  4. Isaac_Pilgrim12

    Windows Package Error

    Boys, I have a problem that don't know how to fix. All of my projects, no matter if it's brand new or not, keep giving me this error, while showing nothing on the Compile Errors window. Can any of you tell me if I'm doing something wrong? Thank you!
  5. E

    Create Executable

    BUILD FAILED in 44s 32 actionable tasks: 31 executed, 1 up-to-date C:\WINDOWS\system32\cmd.exe exited with non-zero status (1) elapsed time 00:01:11.2811350s for command "C:\ProgramData/GameMakerStudio2/Cache/runtimes\runtime-2.3.0.401/bin/Igor.exe" -j=8...
  6. Z

    SOLVED Error Sound in a colision *not set before reading it.*

    ___________________________________________ ############################################################################################ ERROR in action number 1 of Step Eventobj_point for object obj_player: Variable obj_player.snd_comiendo(100026, -2147483648) not set before reading it. at...
  7. Daniel Mallett

    Windows Gamemaker not opening anything

    As of today, I am unable to create new projects. It just flickers and does nothing. The same happens when I open a project. If however, I open a project made before the update, It asks if I want to convert then it errors 'Project load failed. Unable to load /BaseProject/BaseProject.yyp'. I...
  8. Daniel Mallett

    GMS 2.3+ Loading rooms and sounds

    I'm working on a project for someone else. 99% of the code was written by someone else so bear this in mind because this is a very strange issue. I have never experienced this before. 1) I can't access any rooms or sounds that weren't already in the project when I received it. So I create a new...
  9. KyleRansford

    GMS 2.3+ Getting: FAILED: Run Program Complete on a Project that worked on Earlier Versions

    I've installed GMS2 2.3.0 on another PC and on a project that does work in the previous version on GMS2, I keep getting the "FAILED: Run Program Complete" message. I look through the log and don't see anything that looks like an error message relating to code, but I see this long line that I...
  10. L

    GMS 2.3+ Making a crop system; error for an "unknown variable". Need help! (I'm new!)

    Hello! I'm completely new to GMS2 and making games in general, so I really apologize if this is a silly question. I'm currently following this tutorial: The tutorial is to create a farming RPG, and this episode is where we were making the crops "persist" in every room by saving their data at...
  11. I

    Android Android compile error - global tap event is the cause

    Problem: I been trying to build for android using yyc and I keep getting this error Compile errors: Object: obj_ibisflight Event: Global Tap at line 1 : Fatal Error while compiling gml_Object_obj_ibisflight_Gesture_64 - bailing details below Output: collapsing enums. Error ...
  12. K

    String and Ds_Map

    Okay, Basically, what I'm trying to do is the following: I want to create a string that uses a variable in it. The variable is stored inside a Ds_Map When I try to run the game this happens: ___________________________________________...
  13. ShadowLenz

    Windows Making an RPG [PROBLEM FIXED ]

    hi! i'm currently making an RPG and when i established the movement, and solids collision, the firs room map and else, was the time for a new room, so i created a second room, and when i created: the obj_next and obj_last (for tracking back to the previous room) and go to the "step event" of...
  14. T

    Android Please Help. Gradle Error

    My app was working fine a few months ago, but now out of no where when I build to Android I get this: Windows build works fine. p.s. I can't get that stupid smiley face to go away in the Execution failed line.
  15. M

    Drawn shadows overlapping issue

    So in my top-down viewed game, I have cloud shadows (transparent sprites) that occasionally fly over the levels. They overlap tho, causing the overlapping section to go dark, and it looks bad. I tried learning to use Surfaces to overcome this issue..... but honestly i dont have much clue how to...
  16. Kingdom Of Key

    GMS 2.3+ Sprite Animation Don't Move

    My Animation Sprite Don't Move , I Looked At The Mask Collisions And Origin ,Still Doesn't Work script_execute(get_input) //Move yx = (key_up - key_down) xy = (key_left - key_right) //Speed if (xy == 0) and (yx == 0 ) { len =0; } else { len = spd } //Direction var dir =...
  17. mbeytekin

    file_text_open_read() doesn't open file for reading with associated files

    My code like this if projectfile = "" || !file_exists(projectfile) { exit; } var _fname=file_text_open_read(projectfile) ... as you see I checked file exists and then open it for reading. Normally it works, but if I try to double click my programs own associated file and...
  18. B

    Android This release not are compatible with 64 bits

    hello i created my .aab game in GMS2 with this architecture Armv7, x86, Arm64 and x86 64. but when i upload to the google ap store i receid this error Warning This release is not compliant with the Google Play 64-bit requirement The following APKs or App Bundles are available to 64-bit...
  19. F

    Question - IDE Can't install GMS 2.3 mobile

    I got my mobile license and when it tries to install on GMS 2.3 it keeps showing error at the end of installation. It did work before I got GMS mobile and there is no problem with GMS 2, I happened only to 2.3 version.
  20. If Programable_Matter

    Loading JSON info Error

    I keep getting this Error even though the program successfuly uploaded the JSON key :values Apparently the code works and the values show up in my program but like 2 seconds later I get this error. I'm pretty sure I'm missing some code Create Event http_get("http://webpage.json")...
Top