• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!

error

  1. Z

    SOLVED Error Sound in a colision *not set before reading it.*

    ___________________________________________ ############################################################################################ ERROR in action number 1 of Step Eventobj_point for object obj_player: Variable obj_player.snd_comiendo(100026, -2147483648) not set before reading it. at...
  2. Daniel Mallett

    Windows Gamemaker not opening anything

    As of today, I am unable to create new projects. It just flickers and does nothing. The same happens when I open a project. If however, I open a project made before the update, It asks if I want to convert then it errors 'Project load failed. Unable to load /BaseProject/BaseProject.yyp'. I...
  3. Daniel Mallett

    GMS 2.3+ Loading rooms and sounds

    I'm working on a project for someone else. 99% of the code was written by someone else so bear this in mind because this is a very strange issue. I have never experienced this before. 1) I can't access any rooms or sounds that weren't already in the project when I received it. So I create a new...
  4. KyleRansford

    GMS 2.3+ Getting: FAILED: Run Program Complete on a Project that worked on Earlier Versions

    I've installed GMS2 2.3.0 on another PC and on a project that does work in the previous version on GMS2, I keep getting the "FAILED: Run Program Complete" message. I look through the log and don't see anything that looks like an error message relating to code, but I see this long line that I...
  5. L

    GMS 2.3+ Making a crop system; error for an "unknown variable". Need help! (I'm new!)

    Hello! I'm completely new to GMS2 and making games in general, so I really apologize if this is a silly question. I'm currently following this tutorial: The tutorial is to create a farming RPG, and this episode is where we were making the crops "persist" in every room by saving their data at...
  6. I

    Android Android compile error - global tap event is the cause

    Problem: I been trying to build for android using yyc and I keep getting this error Compile errors: Object: obj_ibisflight Event: Global Tap at line 1 : Fatal Error while compiling gml_Object_obj_ibisflight_Gesture_64 - bailing details below Output: collapsing enums. Error ...
  7. K

    String and Ds_Map

    Okay, Basically, what I'm trying to do is the following: I want to create a string that uses a variable in it. The variable is stored inside a Ds_Map When I try to run the game this happens: ___________________________________________...
  8. ShadowLenz

    Windows Making an RPG [PROBLEM FIXED ]

    hi! i'm currently making an RPG and when i established the movement, and solids collision, the firs room map and else, was the time for a new room, so i created a second room, and when i created: the obj_next and obj_last (for tracking back to the previous room) and go to the "step event" of...
  9. T

    Android Please Help. Gradle Error

    My app was working fine a few months ago, but now out of no where when I build to Android I get this: Windows build works fine. p.s. I can't get that stupid smiley face to go away in the Execution failed line.
  10. M

    Drawn shadows overlapping issue

    So in my top-down viewed game, I have cloud shadows (transparent sprites) that occasionally fly over the levels. They overlap tho, causing the overlapping section to go dark, and it looks bad. I tried learning to use Surfaces to overcome this issue..... but honestly i dont have much clue how to...
  11. Kingdom Of Key

    GMS 2.3+ Sprite Animation Don't Move

    My Animation Sprite Don't Move , I Looked At The Mask Collisions And Origin ,Still Doesn't Work script_execute(get_input) //Move yx = (key_up - key_down) xy = (key_left - key_right) //Speed if (xy == 0) and (yx == 0 ) { len =0; } else { len = spd } //Direction var dir =...
  12. mbeytekin

    file_text_open_read() doesn't open file for reading with associated files

    My code like this if projectfile = "" || !file_exists(projectfile) { exit; } var _fname=file_text_open_read(projectfile) ... as you see I checked file exists and then open it for reading. Normally it works, but if I try to double click my programs own associated file and...
  13. B

    Android This release not are compatible with 64 bits

    hello i created my .aab game in GMS2 with this architecture Armv7, x86, Arm64 and x86 64. but when i upload to the google ap store i receid this error Warning This release is not compliant with the Google Play 64-bit requirement The following APKs or App Bundles are available to 64-bit...
  14. F

    Question - IDE Can't install GMS 2.3 mobile

    I got my mobile license and when it tries to install on GMS 2.3 it keeps showing error at the end of installation. It did work before I got GMS mobile and there is no problem with GMS 2, I happened only to 2.3 version.
  15. If Programable_Matter

    Loading JSON info Error

    I keep getting this Error even though the program successfuly uploaded the JSON key :values Apparently the code works and the values show up in my program but like 2 seconds later I get this error. I'm pretty sure I'm missing some code Create Event http_get("http://webpage.json")...
  16. PhenomenalDev

    Legacy GM Attempting to use Fortran dll with GMS1, having issues

    I have produced a dll with gfortran that performs a basic function (shown below) and have attempted to write code to interface with it but I get the classic 'error defining external function' when I attempt to define a function from it and I'm not sure why. I know the function is exposed as I've...
  17. acuacu52699

    Mac OSX GMS Run Error- Port Error

    Hi, I hope I am correct in this thread. I downloaded the GMS for Mac for the first time today and read a bit. Now I wanted to start my project and the following message appears: FAILED: Run Program Complete For the details of why this build failed, please review the whole log above and also...
  18. acuacu52699

    Run Error

    Hi, I hope I am correct in this thread. I downloaded the GMS for Mac for the first time today and read a bit. Now I wanted to start my project and the following message appears: FAILED: Run Program Complete For the details of why this build failed, please review the whole log above and also...
  19. S

    Windows Gamemaker studio 2 login problems

    Hi guys Everytime I logon to my gamemaker studio 2 it says "Error: session not found" This has been a problem for me for months. someone please help me Things I have tried: reinstall gamemaker, reboot computer, delete um.json located in AppData\Roaming\GameMakerStudio2 using another GMS2...
  20. TreysterGames

    This is still happening :(

    Come on man. I was just trying to make a game, but whenever I import a sprite this happens! I restarted my PC uninstalled and re-installed GMS2, and this is still occurring! I don't understand, and any feedback would be helpful! I'm sure if its the file size or what, but I made these sprites in...
Top