• Hey! Guest! The 39th GMC Jam will take place between November 26th, 12:00 UTC and November 30th, 12:00 UTC. Why not join in! Click here to find out more!

error

  1. N

    Windows Can't find file error when testing run the game

    Hello! I'm learning how to use gamemaker so I'm making the clown catch game turtorial in order to learn. I'm finished making the game and can now test run the game. But unfortunately I get an error that it can't find the file? I think it might be because I have game maker installed on my...
  2. Meester Dennis

    GMS 2 Can't Build APK

    Hi there, I cant Build an APK... Can someone help me? What NDK are you using, what BUILD Tools and Support LIB et. are you using? I'm getting this error: My settings are: Hope someone can help me. Greets, Dennis
  3. K

    Mac OSX "Unable to find game!!:" mac testing error

    I made a game for a client, and it is going to be released with html5 in the end, but in the interim I need to send them copies of the game so they can test it and give me notes. I am running osx mojave and they are on osx high sierra, I am running gms2 v2.2.0261 and when I make a YYC build and...
  4. P

    probs destroying ds lists...

    So I'm making a rpg game. I have scripts that initializes their stats stored in a map type ds list. I have scripts for each class, and a script that calls for all of them. I also have a script to "clean the game" ie destroy the ds lists I've created for use when the game session ends (not...
  5. T

    GML [RESOLVED] Variable Error

    Hello guys, I'm creating a tower defense game, and apparently everything works perfectly, but when I'm going to instantiate a new tower and if this tower is created in the 150 pixel test range, this error happens. sorry for English. ___________________________________________...
  6. Carbiner

    GMS 2 Improper instance creation?

    So I'm getting this really weird error where a collision happens with an instance that has no variables. Its ID seems really odd too. If you can't read that, the error message itself says "Fatal Error in action number 1 of Step Event obj_unit for object obj_base Variable...
  7. R

    Android YYC compile - make: *** 'object' Error -1

    when i try to build my android application as YYC in to an APK i get this error, -edit: when compiling as VM on android it works fine, and works fine as VM on windows. cant test YYC on windows as i dont have visual studio. Anyone got any idea what is going on? as i have looked and looked for...
  8. I

    Question - Code Game freezes

    Hello everyone I was following the tutorial on how to make a 2d plataformer. The thing is after writing the code I rund the game and whenever I touch a wall the game stops and freezes any help would be appreciated. Here is the line of code key_left = keyboard_check(vk_left); key_right =...
  9. Anixias

    Question - Code [Solved] Updating Runtime introduced MANY bugs

    Hello. I realized that I had a fairly out-of-date runtime, so I updated to the latest version. Now my entire project is completely unrunnable, randomly crashing from seemingly harmless code. Here is one such case: filename = get_save_filename("World Data|*.wdt",""); if (filename != "" &&...
  10. Ben Allen

    Legacy GM Error referencing line -1

    Just got a crash and was wondering if this is a GameMaker error or something that I did wrong. Not asking for anyone to diagnose the issue, just asking about the (line -1) <unknown source line> bit. ############################################################################################...
  11. K3llyll

    GMS 2 When I change the window size, I see "surface isn't found" error, or surface resets

    I'm working on a drawing program. If I create a surface in create event then I get an error about "surface not found" when I resize the window. If I create the surface in draw event, when I resize the window the surface is automatically aligned to that size and I am not getting an error, but the...
  12. V

    Windows I Just downloaded the update for GM2 but everytime i try to play my game this happens

    "cmd" /c subst Z: "C:\Users\vinicius\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE" elapsed time 00:00:00.0160096s for command "cmd" /c subst Z: "C:\Users\vinicius\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE" started at 10/03/2018 17:12:14 "cmd" /c subst Y...
  13. V

    Question - IDE Game Maker Studio 2 Game doesn't start (F5 Function)

    Hello! I've worked a lot on my new recently. But just as I filled a new room with some objects, I couldn't start my game anymore. There's always the same message: "FAILED: Run Program Complete" I've reinstalled the runtime 3 times and restarted my PC but it didn't do anything. I really...
  14. Bokkie2988

    Windows Error with exploding sprites.

    Hello, I'm getting a error with code I'm using, for exploding a enemy sprite when it dies. I'm using this code: (some things are not from this code) o_enemy create randomize(); my_part=noone; o_enemy collision with laser(what triggers the explosion) { for (i=0;i<15;i++) {...
  15. B

    Legacy GM Error in Step Event0[SOLVED]

    I'm making a game using networking, and I got this error, this shouldn't be a networking error, but I couldn't understand why this was happening. Can someone explain this error, I never made the variable oClient.T , and I’m not trying to read it in the code. Also, I am not sure why it says...
  16. Bokkie2988

    Windows SOLVED

    Hello, When I run gamemaker, I get this error message: String not found: System.IO.DirectoryNotFoundException: Could not find a part of the path 'Z:\manifest'. Can anyone help me? (tried reinstalling gms2) -Bokkie
  17. Edwin

    [SOLVED] How can I update my GameMaker: Studio v1.4.108 to v1.4.999?

    I have a Steam version so I started getting this error: ...looks like when the update came out. Also I started getting script error from this site: https://www-assets.yoyogames.com/assets/application-162c6f46f8bd706162b3882ee7335de4.js. Sorry for russian words, but the problem is same...
  18. G

    GML Problems with colissions (SOLVED)

    Hi, I have problem with colission. When the obj_player collides with the obj_limits this one (obj_player) it stays out of the screen and I can't move it. Can you help? This is the code I use: What would be the problem? Thanks for helping :)
  19. PlayerOne

    GMS 2 Debug mode keeps pausing every frame

    Exactly what the title says. For some reason this keeps happening and just refuses to run. Nothing happens when running it normally, but in debug mode it just pauses no matter how many time I keep pressing F5. No error messages, nothing I can post. Just that it registers a pause event in the...
  20. R

    Question - Code Game freezes after half a second [SOLVED]

    Hi there, I'm having an issue with my game that I can't quite get my head around. After running for half a second, my game freezes (all animations and movement stop), but the background music keeps playing. What is strange is that the console does not output any error. EVEN MORE BIZARRE : I...
Top