error

  1. J

    Ingreso de texto por teclado para aplicación creada en GMS2 para Android.

    Buenas tardes con todos, quisiera solicitar su ayuda por favor. Lo que pasa es que desarrollé un juego en Game Maker Studio 2 como proyecto de tésis de la Universidad, en el cual antes de iniciar presento una pantalla donde el usuario debe introducir su nombre para asignarle ese nombre al...
  2. AnnoyingDoggoX

    SOLVED Got '' expected } or and | Last line error

    Object: obj_grid Event: Step at line 20 : got '' expected '}' I have no idea why I got this error, even when I add } or end it just says the same thing if image_index > 87 { image_speed = 0; //when skill button not selected if global.skill_select == 0 { obj_grid.image_speed = -1.5; if...
  3. C

    GMS 2.3+ "Invalid Shader" Error Message

    Hello! I've been trying to find a solution to this issue for a couple of hours now. Every thread I found seemed to come to the conclusion of reinstalling direct_x or something from Microsoft (I forgot what it was called already). Anyways, all I'm doing is trying to make a fragment shader that...
  4. M

    Exception - The remote server returned an error. (504) Gateway Timeout - Login?

    Can't seem to login without an error message popping up. "Exception - The remote server returned an error. (504) Gateway Timeout" Is this on my end? thanks
  5. Pedro D'Agrofloresta

    Windows Unable to finde suitable driver, mesa files GMS2 error

    I had to format my pc a few days ago, now I'm trying to install GameMakerStudio2 and this error is persisting, has anyone dealt with this error? I didn't find anything related to him on Google. Gratitude for the help!
  6. M

    GMS 2.3+ Indie Subscription Not Active

    Hi everyone, I recently just purchased the Indie subscription on the YoYo subscriptions, but it's not showing up on my purchase history, and I do not have the option to put Android as my platform setting, as you can see by the screenshot. I just paid the $9.99 for the monthly subscription...
  7. M

    Unknown Error/Crash Message

    Hi everyone, I'm currently testing the apk of my game on my phone. At a certain point in testing, the game crashes and I get this error message (attached). It doesn't mention any variable that I have, and it doesn't give any information on where the bug or error is. Please help, Thank you.
  8. M

    GMS 2 android export

    "cmd" /c subst Z: "C:\Users\Mustafa\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE" elapsed time 00:00:00.1019363s for command "cmd" /c subst Z: "C:\Users\Mustafa\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE" started at 12/20/2021 22:47:30 "cmd" /c subst Y...
  9. S

    Help! I can't pay for GMS2 again in YOYOGAMES website

    Hello, When I try paying for the subscription, I get this message but I am unable to change anything in my setting for this:
  10. Alemar5

    SOLVED Error opening my game

    Help, I'm scared, yesterday I opened my file and everything was fine but today I tried to open my game and I got this error, someone knows a solution :,3
  11. S

    Question - IDE Running my program isn't working

    Hello! This is my first-day trying GameMaker Studio 2 and just Game dev in general. I am quite new to this, and I've been following the 'Little Town tutorial'. I'm on session 1, "episode" 7 currently. This one's about running your program - I was trying that, and I've tried several times and it...
  12. Totofer77

    SOLVED How can I play the game despite having unused Variables?

    Well, I don't know if I'm the only one to complain about a problem like that, but the game won't load all because I have unused Variables Here is the Output : "cmd" /c subst Z: "C:\Users\totop\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE" elapsed time 00:00:00.0759998s for command "cmd"...
  13. S

    Windows I cannot test run my game

    I opened my project today after not working on it for a month, but now I am not able to run the game to test it. I am not sure what is wrong since I was able to open it fine a month ago and it all of the sudden stopped working. There is nothing in compile errors, but I checked Output and this is...
  14. yaragad

    Android Get Key failed: Given final block not properly padded. Such issues can arise if a bad key is used during decryption.

    Hi. While building an .apk for Android / local / YYC on 2.3.5.458 and get the error below. - When I click on Show Key, it works correctly. - Im runing same SKD, NDK and JRE than in the instructions, and they are installed. - This error happens after 3 minutes, so I think game is compiled...
  15. If Programable_Matter

    Currently have Enterprise Subscription and HTML5 is always messing up

    What is the whole point of having the Enterprise subscription when HTML5 program is constantly getting corrupted and crashing with the sprites or other compiling errors.... I currently get the following errors... and I have already used the cleaning brush cache [GMWebServer] Unhandled...
  16. thom

    Memory error at every new update (The memory could not be read)

    Hi, every time I make a new update for my game (after exporting on windows) and the game is launched it will give the following error: The instruction at 0x0000000001D77080 referenced memory at 0x0000000000000000. The memory could not be read. Now when I press ok, it will just launch the game...
  17. L

    enemy

    Olá, há alguns dias estou tentando encontrar um bug no meu código para criar um inimigo. Se alguem puder me ajudar fico muito grato etapa: if (distance_to_object (obj_player) <150 && hp> 0) { mp_potential_step_object (obj_player.x, obj_player.y, vel_enemy, true); } if (hp <= 0) { temporizador +...
  18. ThePlayerEden

    GMS 2 ERROR - Variable Index [3] out of range [3] (SOLVED)

    Hi ya'll! So I'm getting this error, I was following a tutorial on youtube, anyways I was doing good, and then afterward this popped up and I've looked through all I know and rewatched the video multiple times. I'm still pretty new to all this so I'm stumped. Here's the error I got...
  19. M

    Error message upon creating executable

    Hi so I'm pretty new to Game Maker and I just finished one of the tutorials. I've been able to create an installer using the zip instead of making an executable. Whenever I try to create an installer I continue to get this message LicenseData: open failed...
  20. 2

    GMS 2.3+ GMS 2.3.4 Quits on Start Up

    I upgraded to the newest stable and it won't run. I think I upgraded from 2.3.3 (which worked fine) to 2.3.4. When I double click the GMS2 icon it appears on my taskbar and right when it is about to display something onscreen it quits with no error message. The screen fills with white/gray that...
Top