• Hey! Guest! The 37th GMC Jam will take place between May 28th, 12:00 UTC and June 1st, 12:00 UTC. Why not join in! Click here to find out more!

compiling

  1. P

    Windows Compile time abnormally long; tried a few things but it didn't work. Any suggestions?

    Hey there people! I've been developing a game with four of my buddies (their first time making games) and we're having a blast! Problem is, as of yesterday one of these buddies has been having a few tech issues which are really putting him off. For some reason, his compile time inexplicably...
  2. M

    Run unchanged Game again without re-compiling

    Hi guys I dlike to optimize the development time of my game a little bit. Is there a way to re-run a game without re-compiling the code, if i haven't changed anything? (This would sometimes save a lot time, when im testing the game)...
  3. Marko03970

    Android / Amazon Fire Android problem

    Can anyone explain me what is the problem and how to fix that please?
  4. Marko03970

    Problem with creating application (exporting project)

    I did everything from YouTube video but i'm getting this error and application can't be built. Anyone that know how to fix it?
  5. Z

    How does GM compile and create a .exe out of a project?

    Hi everyone, I'm asking this because well, I'm kind of amazed. I've been making graphics for 3500+ hours now (actually longer, but this is just for 1 2D top down RPG style, basically as much as I could think of) and for the past week I've been importing and importing, and then even more...
  6. P

    Android / Amazon Fire (solved) What does it mean? Screen flashes while compiling

    Hi, when I compile a game for android, Game Maker flashes white once in a while. Does it mean something?
  7. flykidsblue1

    Discussion Android Compiling Problem(Gamemaker Studio 2 Version 2.2.1)

    Hey everyone! After the new update I can no longer compile for YYC in android. I have been trying to find the root of the issue with no avail. It seems that there is a swap of directories because I am having the "droid" directory pointing to "Y:\\" rather than c. I'll be leavng the compiling...
  8. K

    Mac OSX Having a compiling nightmare!

    I've been using GMS2 (Creator edition) for about 6 months and I have been using the play/run button to play the game I have been developing. Yesterday I tried to compile a standalone version and I am getting nowhere! Using the VM option (the only option in creator) I get 'FAILED: Package...
  9. T

    Android / Amazon Fire why mapped drive on compiling for android?

    Hello, I noticed that GMS2 creats a mapped drive on compiling for Android. I would like to change this to a static location. Is this possible?
  10. J

    Question - IDE Compile Time Slower Than It Could Be?

    When I compile a game on the Mac Ide, It pauses a few times while compiling, even though it shows that it finished. Once at, Compile Rooms...finished. And another time at, Global scripts...finished. And at, Writing Chunk... STRG This adds at least 5 seconds to the compile time, even on...
  11. J

    Windows False positive with all versions of executables (exe, zip, and installer) - Game detected as virus.

    Hey all. So I got a problem that has been getting on my nerves for the past couple of days. I just published (drafted) a small project on itch.io, yet every time I create an executable (compile the game) in any form (exe, zip, or installer) Windows Defender sees it as a virus. I have confirmed...
  12. Nathan Matthews

    Game Maker 8.1 - Raspberry Pi, Compiling with Linux

    I was wondering if you are able to compile Game Maker 8.1 Games for Linux?
  13. A

    Android / Amazon Fire Will someone PLEASE help me with this Android error compile!

    I've been at this for a week now and its killing me! Here is this error that I keep getting no matter what I change. C:\WINDOWS\system32\cmd.exe /c "subst X: "C:\Users\DJ AVOX\AppData\Roaming\GameMakerStudio2\Cache\GMS2CACHE\InfinityJu_F18EE54A_5515C637\Android\default" && X: && cd...
  14. A

    Android / Amazon Fire Error compiling APK(Android) Permissions?

    I've been trying to compile it to APK/RUN it on my phone but i continuously get these errors. Have SDK,NDK installed and everything think it has to do with compiling. C:\ProgramData\GameMakerStudio2\Cache\runtimes\runtime-2.1.0.144/bin/GMAssetCompiler.exe /c /zpex /mv=1 /iv=0 /rv=0 /bv=0 /j=6...
  15. P

    Question - IDE Error when building game as Zip

    Exception during processing ICSharpCode.SharpZipLib.Zip.ZipException: Entry size/stream size mismatch at ICSharpCode.SharpZipLib.Zip.ZipFile.AddEntry(ZipFile workFile, ZipUpdate update) at ICSharpCode.SharpZipLib.Zip.ZipFile.RunUpdates() at...
  16. T

     Unable to test run any projects

    Just installed version 2.0.6.93 of GMS2 (was using version 2.0.5.49 previously), and I am unable to test run my projects at all. Attempting to test projects on Windows and HTML5 only pops up one message in the compiler window saying that it's saving the project, like this: 'Saving project to...
  17. M

    Android / Amazon Fire Compiling creates "uninitialized variable" error

    Hey guys! It's been a while :) Before I get a comment saying there is an error in my code, allow me to explain :p : The game works flawlessly when compiled and ran with the target set to Windows. The error is also showing that it comes from objects that are NOT in the first room and therefor...
  18. R

    Igor.exe in use by another process?

    Hello! I just completed my first tutorial game and was attempting to Build it, but I keep getting this rather arcane error message that no one can seem to figure out. What's going on with my computer that's preventing it from accessing this "Igor.exe" program? I've appended a screenshot of my...
  19. A

    Windows HELP GMS2 running the game

    I just updated my GMS2 yesterday (1/28/17) and after that I can't run my game. Whenever I press the run button (Triangle thing) it does the compiling stuff and at the end this shows up. C:\WINDOWS\system32\cmd.exe exited with non-zero status (1) elapsed time 00:00:04.3713729s for command...
  20. L

    Windows Some issues with compiling

    So, I have this weird problem with NSIS installer format. It compiles just fine, but when I try it out, it runs very weirdly. Some of my code wont run at all (like loops etc.) an none of my sounds or music won't play. I tried to click that "broom" but that didn't do anything. I don't know what...
Top