compile

  1. U

    Can't Compile to android GMS 1.4

    hey i triying to compile my game to android but i can't because of this error: * What went wrong: A problem occurred configuring project ':com.unorg.projectozone'. > Could not resolve all dependencies for configuration ':com.unorg.projectozone:_debugCompile'. > Could not resolve...
  2. G

    Android / Amazon Fire [SOLVED] Problems with android build - help!

    Hi, I've been trying to compile my game to android and it keeps giving me this error log What went wrong: Execution failed for task ':com.gumbosoup.colorsnakesmash:processDebugResources'. Android resource linking failed W:\com.gumbosoup.colorsnakesmash\src\main\res\layout\download.xml:13...
  3. P

    Windows Compile time abnormally long; tried a few things but it didn't work. Any suggestions?

    Hey there people! I've been developing a game with four of my buddies (their first time making games) and we're having a blast! Problem is, as of yesterday one of these buddies has been having a few tech issues which are really putting him off. For some reason, his compile time inexplicably...
  4. RizbIT

    Does the 1.4x UWP module still work

    Im trying to just make a small minor update to a UWP app. I only have the UWP module for 1.4x. Not updated any UWP stuff for a while. I just tried to compile a new UWP app and I get the error: SignTool Error: No certificates were found that met all the given criteria. cmd /c "Powershell...
  5. Gabriel Amici

    Android / Amazon Fire Issue making game run in Android

    When I try to compile my game using VM mode it interrupts compiling with the following error: I have tried to do the same thing in other projects and it works fine. I then examined all the Android Options to see if they matched between the two projects and they were identical. I will attach...
  6. Tyler D. Anderson

    Shaders Why does GMS2 leave the shader code exposed in the final export?

    If I have an empty project with a simple shader: // // Simple passthrough fragment shader // varying vec2 v_vTexcoord; varying vec4 v_vColour; void main() { float two = 2.; gl_FragColor = v_vColour * texture2D( gm_BaseTexture, v_vTexcoord ) * two; } And I then compile it to a zip - I...
  7. Carcophan

    HTML5 Getting an "error out of bounds" issue in HTML5 but not in Windows

    Hello Everyone! I have stumbled into a strange error that only seems to exist in, and crash, my Chrome/HTML5 compiles. It is not recognized as an error during a Windows compile in F5/F6 - which seems to run just fine. There are no errors in the debugger window for Windows - nor the HTML5...
  8. matharoo

    Android / Amazon Fire Android compile error - package com.google.android.gms.gcm does not exist

    Hey, I recently tried to build a project that I last compiled for Android a few months back. I deleted the Google Play Services extensions and installed the latest version. Now I get these errors (seems like it can't find the gcm dependency)...
  9. M

    Android / Amazon Fire [Solved]Compiling APK

    I followed the guide https://help.yoyogames.com/hc/en-us/articles/115001368727-Setting-Up-For-Android When I compile an to an .apk I get this in IDE/debug: Starting a Gradle Daemon, 1 incompatible and 1 stopped Daemons could not be reused, use --status for details File...
  10. S

    Shaders (SOLVED)(compile) Packing Error

    I keep getting an error saying it can't pack a variable in a shader I've written, the shader worked fine until I updated it today to add more colors. Does anyone have experience debugging packing errors? Vertex shader Fragment shader
  11. jigglesthepuff

    Legacy GM Android compile issue [SOLVED]

    Hello! I am trying to get my game to run on my android device but it always fails to compile. I've downloaded the SDK, NDK, and JDK; setup the keystore; and purchased the export module but it still isn't working. I am using Gamemaker 1.4 by the way. Any help or troubleshooting suggestions are...
  12. J

    Windows Output delay AFTER 'Options: [Path]\MainOptions.json and BEFORE Attempt to set gamepadcount [SOLVED]

    Edited Title and Main Post for clarity of issue and solution. Hello, I have tried searching for this issue and found 1 other unanswered thread that was similar however I cannot figure out what is wrong. When I go to build even something as simple as an empty room with a red square in it, the...
  13. DarthTenebris

    Linux Compiling Game Maker Studio 2 Projects on Linux

    Hello everybody, I have managed to install and run Game Maker Studio 2.2.1.375 with Runtime 2.2.1.291 on Ubuntu 19.04 with the help of Wine 4.0, however when I tried to compile for Ubuntu it couldn't recognize the host machine, and when I tried to compile for Windows, it didn't like it either...
  14. Gabriel

    Android / Amazon Fire Can't compile using latest version of Google Play Services Extension

    Due to the Google+ deprecation, since my game is using version 3.0.5 of the Google Play Services extension, these services are not funcional anymore. When I downloaded the latest version (3.1.1) which takes the Google+ API away, without changing a single setting, GMS2 won't let me compile...
  15. Daniel Mallett

    Why am I freezing

    I have s script with the following code: letter_string = ""; // Stores letter string number = argument0; // The nth number to be converted into a string multiply = ceil((number - 26) / 26); // The number of times to add A to the letter string end_letter_number = number - (multiply * 26) + 64...
  16. Kabcorp

    Question - IDE YYC generate 'data.win' too

    Hello, I have a question: I use ZIP build of my GM:S 2 projects for sharing. I realized if I compile with YYC or using VM built, in the ZIP file, I have in both cases the famous 'data.win' file in. This 'data.win' file is not the same when I use YYC and VM. The EXE file need the 'data.win' to...
  17. J

    Question - IDE [SOLVED] Can't compile game!

    Hey guys. I get this when I try to create and executable. I don't know what it means, so please help me!
  18. Doc

    GMS 2 [SOLVED]Way to make final game portable?

    Sorry if this is a noob question, but is there a way to make your final game output "portable"? As in not having to install it to the local machine, but just run the executable out of a zipped folder?
  19. Geniusy

    Compile Problem

    There was no problem before formatting my pc. After formatting, GameMaker started to compile too long. Every project is same. (GMS 1.4.9999)
  20. Clemens van Brunschot

    Question - IDE Compiling error

    Hi all, When compiling a game for Android with YYC setting and SDK 28 I get in my log (I replaced personal info by ...): "...:compileReleaseNdk UP-TO-DATE ... :compileReleaseSources [Fatal Error] :3:214: The value of attribute "name" associated with an element type "item" must not contain the...
Top