compilation error

  1. P

    GMS 2.3+ Build fails under macOS Monterey

    Hello everyone! I have recently reset my MacBook and since then, GameMaker Studio 2 fails to build my projects. I tested both Beta and non-Beta and different runtimes. Here is literally all the log displayed: "/Library/Frameworks/Mono.framework/Versions/Current/Commands/mono"...
  2. cenowador

    iOS Game compiles on Mac, but not on iOS

    Hi! I'm trying to compile a game for iOS but it's not working out. I've followed Yoyo articles about setting up and managed to compile my game for Mac (both VM and YYC), however, when trying to compile for iOS (or even cleaning cache), I get this exception: Setting up core libraries.. DONE...
  3. F

    Android Error al compilar

    Buenas, desde ayer estoy intentando resolver un problema con la compilacion de GameMaker Studio 2. Quiero hacer un juego para la plataforma Android, pero a la hora de compilar el juego(crear el .APK) me sale error, esto es lo que me sale en la consola cuando doy click en el boton Compilar. Este...
  4. G

    Windows Problem when i'm trying to create a exe.

    Good evening I have a problem with the creation of an executable. I am a beginner and I understand nothing at all about this error. I tried with a new project and everything works fine, but with this one nothing to do. If anyone can explain to me how to solve my problem thank you. "cmd" /c...
  5. Memoh

    Game Maker Studio 2 - Building Forever

    Hello, I have also had, like many others, the problem that when compiling the project, it stays in "Building" forever and my games do not run, even if it is just an empty room. Here I leave a picture of how it looks and what the compiler shows As you can see, the compiler gets stuck...
  6. F

    Android Can't compile android build

    For some reason I cannot make APK for a game I'm working on. It says the path is not supported however when I made new empty project in the same exact folder I could compile it without any issues. Here are few last lines of log that shows the error. edit: It's worth to mention that "Format...
  7. Outseidr

    Android help! error on compile

    trying to compile for android when: ================== (the ending of the compilation) 47 errors FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ':v1.OutseidrMedia.Pounce:compileDebugJavaWithJavac'. > Compilation failed; see the compiler error output...
  8. Bune Duggy

    Windows Runner.exe exited with non-zero status (-1073741819)

    Hey, all of a sudden my game isn't compiling and I'm not sure why. I'm hoping somebody here can help me out with this because I've seen a lot of other issues I've had with GMS 2.3 posted here. I get this at the end of the compile in the Output window: V://windows/Runner.exe exited with...
  9. M

    'Error : Unable to find object <undefined> referenced in event'

    Hi, so I deleted an object from my game which had many references. Instead of just deleting it, it spawned an error pop up when I deleted the object, and the object itself just turned into an <undefined> instance and didn't get deleted until I clicked delete on it again. After this, the game...
  10. K

    Discussion Permission Error : Unable to obtain permission to execute

    when i compile my project, I get error: Permission Error : Unable to obtain permission to execute. How to fix?
  11. Erramir

    Android Compiling Error: UnauthorizedAccessException

    Greetings! i am having problems compiling my first ever game to mobile(android) , so mind me if i do silly questions, or the solution is simple. However i DO tried to solve it by googling the problem and "solution". First of all, yesterday i set up all the things related to compiling a game for...
  12. B

    Android [Solved] Problem while builiding either with VM or YYC

    Hello all. I've whatched a bunch of posts about this but unfortunately none of them solved my problem. It gives "BUILD FAILED" either if I compile in VM or in YYC. YYC log here. VM log here. Android configurations here. I've disabled Lint. I've desabled google licensing and I don't know...
  13. M

    Android [Solved]Android Compilation adb

    i can compile an .apk but get this in debug adb: failed to install C:\Users\magnu\Downloads\2d_platformerSmGl.apk: Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113] Performing Streamed Install
Top