bugs

  1. D

    Question - IDE GameMaker Studio 2 font in editor is almost unreadable

    GameMaker Studio 2 font in editor is almost unreadable Windows 10 64 bit font in editor looks blurred, font settings: consolas , regular, size 10, 14, 16 no improvement this is not a pleasant coding experience video drivers up to date, window anti-aliasing on etc I have a top end video...
  2. R

    Sprite only moves after I jump?

    Hello all !! I’m trying to figure a bug out I only started coding a few days ago and I have my sprites in and moving as far as the minimum basics but when I run the game my sprite won’t walk from left to right until I jump then after that it works like a charm any help would be great
  3. Xalezar

    HTML5 Is mp_potential_path not available for HTML5?

    Hi Everyone, I've been testing my game locally on the "Test" platform (set with the target icon in the upper right corner) and I am able to get my enemies to chase the player, but when I tested it on the "HTML5" platform, the motion planning function doesn't seem to have any effect and my...
  4. Erik

    Major BUGS in GMS2. Anyone else?

    I have started a project and everything was working great. Its a large flipscreen platformer but some strange bugs that i have never encountered before have shown up. I had uppdated to a later version of gms2 and i don't know if this is version dependent. Bug 1 : I had perfected my platform...
  5. TheSpydog

    Suggestion Improving the bug reporting process

    Today I've been thinking a lot about the problems with GM's current issue tracking / bug fixing system. From the user's perspective, the process for requesting bug fixes currently goes like this: 1. Report a bug 2. Wait for a response from helpdesk (could take days/weeks/months...) 3. Helpdesk...
  6. Vinsane

    Question - IDE Constant Object Flickering + Project Crashing

    Hi everyone, I'm just wondering if I can get some assistance with one of the most annoying bugs I've encountered so far on GMS2. I've recently finished creating a PC game by the way and didn't have anywhere near as much issues as I am now trying to build to Android but I still had issues with...
  7. C

    lengthdir malformed with statement

    i even used the code from the manual and it doesnt work /// randomly shoot can_shoot -= 1; event_inherited(); xoffset = x + lengthdir_x(5, obj_rotTurret.image_angle) yoffset = y + lengthdir_y(5, obj_rotTurret.image_angle) //xoffset = x + cos(image_angle * pi / 180) * 5 //yoffset = y +...
  8. U

    GML Getting stuck in the floor in walls

    In Game Maker Studio 1.4.1772, I'm following this tutorial on how to make a sonic game in game maker and by the end of the first video I am getting stuck in the floors when I jump on them and stuck into walls while walking into them. Part of the issue may be my confusion with collision and...
  9. I

    Is this a bug with "while" expression?

    Hi guys, i found this quite odd and wonder is this a bug? if i run this code: ev_file = file_text_open_read("abc.txt"); while (file_text_read_string(ev_file) != "") { array1[z] = file_text_read_string(ev_file); z++; file_text_realln(ev_file); show_message(array1[z]); } array1 will receive weird...
  10. Aaron Craig

    Windows Keyboard arrow check bug

    Greetings. I believe there's a small bug when checking the arrow keys and the spacebar (spacebar appears to be the worst culprit, though I've tried other keys and they have problems, too). I've got this code inside of an object: if(keyboard_check(vk_right)) x += 15...
  11. Divinik

    Windows Controller not working after being unplugged?

    I'm using the standard input variables for my controller code: if gamepad_is_connected(0) { sprite_index = x; //insert input options here } else {//keyboard options}; After my controller was unplugged (using a PS4 controller with DS4 Windows, Xinput), it no longer registers when...
  12. Divinik

    Legacy GM Keyboard/Gamepad Input Limit?

    I'm currently developing a platformer beat-em-up RPG. I use "gamepad_button_check_pressed(0,gp_face1)" and "keyboard_check_pressed(vk_enter)" for menu option selection. I created a new object and now the input values won't work for it. Does any body know why this is happening?
  13. D

    Legacy GM A comparison of 2 "visually" equal numbers doesn't return true

    Hello all, I'm having this problem for a while now and it's really driving me nuts. First of all this is the relevant code: if jerked { var jerkSpeed = fireSpeed; var jerkHspeed = abs(lengthdir_x(jerkSpeed, jerkAngle)); var jerkVspeed = abs(lengthdir_y(jerkSpeed, jerkAngle)); x...
  14. C

    GameMaker 1.4.1772 strange behavior

    I will try and add some more information as I figure this out, but ever since the update I've been getting some odd errors, I haven't been able to pinpoint the exact cause of them as of yet, but they seem to stem from some of the following functions: instance_change (GML), sprite_change...
  15. A

    UWP Mouse Cursor Displaying in build

    I am trying to build my game for UWP but the original mouse cursor displays when I run the game. I've unchecked the checkbox to display mouse and have used window_set_cursor(cr_none). It works on all other builds (MAC, PC, Linux) but UWP shows the original cursor. Also, the cursor shows up in...
  16. Y

    GML My ball keeps getting stuck to the wall and paddles[GM:S]

    I'm making a pong like game for android and I've got some issues with collisions between the ball and walls and between the ball and paddles. The ball keeps getting stuck at corners and also in between the paddle and the wall... Here's what it looks like getting stuck at a corner ...
  17. E

    Windows instance spawn bug

    SOLVED. thanks for responding. dead thread.
  18. A

    Android AndroidManifest.xml dangerous permission is automatically injected

    Creating a new empty project without any extension and choosing Android as the target, will generate an APK with the following permissions in AndroidManifest.xml: <!-- uses here --> <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" /> <uses-permission...
  19. M

    Drag And Drop FATAL ERROR in action number 1 of Step Event0

    Hey I' working at this tutorial: And I got error: FATAL ERROR in action number 1 of Step Event0 for object obj_player: Variable obj_player.variable(100003, -2147483648) not set before reading it. at gml_Object_obj_player_Step_0 (line 26) - if(variable <= 0) I checked everything many...
  20. FrostyCat

    Graphics Checklist for Missing Text Bugs

    Checklist for Missing Text Bugs GM Version: ALL Target Platform: ALL Download: N/A Links: N/A Preface This checklist details the most common causes of bugs involving missing on-screen text. An answer of "Yes" to any item in the list requires your attention. Object Setup and Code Is the...
Top