asset compiler

  1. R

    Android Help Please!! Asset Compiler Trowing Error Code (1)

    When trying to compile my game on to windows, it compiles fine. no issues no worries. but this is going to be an android game, and when compiling on to android the Asset Compiler throws an error and i cant figure out what is causing it at all! ALL help is much appreciated! and i thank you all...
  2. kakatoto

    Windows BUG with the new runtime : GameMaker:Studio has encountered a problem,

    Hello, SInce the installation of the runtime 2.1.5.246, I have this message : Furthermore, the VM always stops a this point : I wonder what the chunk SOND is ? SOUND ?? It would help...
  3. J

    Error when going to run any project. Failed:Run Program Complete

    In GameMaker studio 2 every time i trie to run a program it gives me a asset compiler error. Even in a project i started up only contaning the default room given when starting a new project. I started it up using GML but i doubt that matters. I also doubt my save location matters as it is in...
  4. E

    Question - IDE [SOLVED] Asset Compiler Error - Instance Issue

    Hey! I already submited a bug report for this, but I haven't got a response in a while (I think?) so I'm trying my luck here. After updating to the last GMS2 version this message started appearing while compiling, which says: "Reference to object isn't stablished as an instance of an object"...
  5. bsabiston

    Discussion AssetCompiler : One or more errors occurred -- all the time!

    I have to try four or five times to run my game before it will actually launch. Anyone else repeatedly get this stupid error dialog box? I don't have any compile errors in my game. I just have to keep mashing the triangle button until eventually it will run. Sometimes cleaning helps...
  6. Petr Skornok

    Mac OSX Asset Compiler hell

    Hi guys, I am running GM:S2, IDE v2.1.4.288, Runtime v2.1.4.203 on macOS and the last few weeks I am experiencing more and more these Asset Compiler crashes. The game compiles 1 out of 10 times and I've tried searching around forums, grasping to every possible piece of information but...
  7. V

    Windows Asset Compile Issue with debug/run/clean up

    Sorry for making another post like this and I see other people have the same issue with this but when I follow their example and solutions, I still run into the same problem as from before or even worse from before. I tried putting %SystemRoot%\System32; on my system variable in path but it...
  8. W

    Mac OSX Getting this error: "AssetCompiler has encountered a problem"

    I began getting this error message just now. The game was running perfectly fine at first. Any thoughts?
  9. A

    Question - IDE Issue with asset compiler

    Hello, When I re-use sprites I created in GMS 2, apply them to an object and place in the room, the asset compiler throws this out. (I am moving them from a GML project to DnD) "An Item with the same key has already been added" I have tried the clean button and it throws the same error. I am...
  10. Ricardo

    HTML5 I need to "clean" the project all the time

    Hi there, While I am working in my project in GMS2 (2.0.7.110) testing in HTML5, I've noticed that the textures get messed up quite frequently, forcing me to press the "Clean" button to flush the compiler cache. In GMS 1.4, the clean button were usually necessary when adding/removing assets. In...
  11. K

    Windows Asset Compiler has encountered a problem -Found Workaround-

    I have been struggling today trying to run my project. Earlier today I was having an AssetCompiler error and it stated: GameMaker:Studio AssetCompiler has encountered a problem. We are sorry for the inconvenience. Value Cannot Be Null. Parameter Name: path2 I got around this error by...
  12. F

    Windows YYC Compiler Error "the given key was not present in the dictionary"

    Hi there. I've been having some issue with the YYC compiler for GMS2. The system output consistently gets to "Writing Chunk... AUDO" and an error pops up saying "The given key was not present in the dictionary". I've tried compiling multiple different projects files (being sure to clear the...
Top