android

  1. Gabriel Amici

    Android Issue making game run in Android

    When I try to compile my game using VM mode it interrupts compiling with the following error: I have tried to do the same thing in other projects and it works fine. I then examined all the Android Options to see if they matched between the two projects and they were identical. I will attach...
  2. Lite

    GMS 2 Allowing players to import files

    My goal is to allow players to import their own character icon into the game. I'm trying to do this on android devices if that's possible just clueless as to the syntax used to locate the file and import it correctly. CharacterSprite = *players chosen image file*; Can Gamemaker 2 grant access...
  3. Kubawsky

    GMS 2 iOS vs Android audio processing, headphones mode vs speaker

    Hello In the mobile phone game I'm working on, I've built a music-making sequencer of sorts. The way it works is that separate audio tracks (3 instruments with notes and 2 'drummers') are being played simultaneously, playing different notes at different moments, playing different songs this way...
  4. Marko03970

    Android Ads don't show when run the game

    Hi, I'm making ads in my game, and it is working test ads. But when I set false in GoogleMobileAds_UseTestAds, and when I run game on my phone, I can't see ads. What is the problem? I don't publish my game yet, I just created apk and downloaded it on the phone, is that a problem? Thanks
  5. clee2005

    Question - Code Array out of range

    Hey gang! I'm getting this error randomly from some users and am trying to figure out how this might be happening : Push :: Execution Error - Variable Index [0,2] out of range [5,0] - -1.mask(100160,2) My understanding is that it's saying my array var named mask is attempting to be accessed...
  6. Marko03970

    Android Android ads

    Hello everyone. Again, I have problems with implementing ads in my game. I tried with test ads and I'm getting this error: "Error while pinging URL....". Before it was working well, but now I'm getting this error. I updated all sdks in sdk manager but still don't work.
  7. bluetrack

    Android Select active Gamepad

    MACOS IDE: v.2.2.5.481 Runtime: v.2.2.5.378 Hi, is there a way to select automatically one gamepad of the ones GM:S detects and set it as default? For instance on Android and specificlly on AndroidTV there are various inputs detected and put on different slots. (eg. SONY input service...
  8. LisaC

    Android Saving A Screenshot outside sandbox - Either sharing or saving to specific area.

    Hello. I would like to save a screenshot on Android so that the user can keep it and print it from another application. I see in the docs "file system limits" document that I am unable to save outside the "sandbox"... but my users will not be experienced enough to find the screenshots in the...
  9. samspade

    Asset - Extension Simple Multitouch

    Available for GMS 2 Description An extension to make working with multiple touches easy! While the built-in Gesture Events are suitable for many purposes, this extension fills in the gaps or simply gives you greater control. Import the extension and gain access to all the functions. Heavily...
  10. hykwf233

    Android [solved]Crash when running

    Runtime crashes but works fine in debug mode. The error code is as follows, does anyone know what is going on? --------- beginning of main 12-20 16:33:25.056 3504 10279 I Ads : Parental control value is stale. Refreshing. 12-20 16:33:25.205 3504 10279 I Ads : Initialized AdMob in...
  11. W

    Android Game Maker 2 can't find NDK file

    I got Android Studio in an attempt to convert a Game Maker project over to Android. I downloaded the SDK, and Game Maker found that with no problem. I was using a tutorial online to do this and in it they just checked this box that had was labeled NDK in Android Studio, but when I went to check...
  12. Dilawlaw

    Discussion GMS 2 Android YYC compiler take hours

    Hi everyone, I just wanted to know if its normal that gamemaker studio 2 take hours ( between 1:50 to 2:10 exactly) to compile my android game in aab format (Android App Bundle), knowing that the apk takes hardly few mints I have an i7 4th gen, GMS installed on SSD and got an AMD RX560 GPU...
  13. hykwf233

    Android [SOLVED]Questions about Google ad Mob display

    I can show ads when I use Google adMob test ID, but I can't load ads when I use my own ID. Google adMob can see the number of requests in the background. Does anyone know what is going on?
  14. Mehdi

    Android [SOLVED]I can't build using YYC compiler for Android any more.

    I used to get easy YYC builds for android last week. But I don't seem to be able to do so right now. I've changed nothing special. But when I try to use YYC it takes too long,then RAM usage gets too high, my laptop starts crying and nothing happens., Apparently something is wrong with NDK...
  15. shibao

    Released My first App has sold! Help me to subscribe ... Youtube

    I use GMS2 made a tool App. Name is "LanLanDe PinYin" This is the function of learning Chinese pinyin. This is a Chinese phonetic learning software made by his father for his daughter, which has been used and improved for many years. The current version contains 3 functions. Function 1...
  16. RizbIT

    usesCleartextTraffic

    I just wanted to check is there anything wrong with adding this to the 'Inject To Android Manifest Application' section? <activity android:usesCleartextTraffic="true" android:name=".WebViewEmbed" android:theme="@android:style/Theme.Translucent"/> The reason is that in Android Pie (API 29)...
  17. KironDevCoder

    Android Can't export to Android

    I keep getting this javax.net.ssl.SSLException: Received fatal alert: protocol_version error, can someone please take a look? https://pastebin.com/htcRDfsa
  18. Mehdi

    Android Texture Page

    Hi guys, Can anyone tell me how many texture pages is not too many for android? Or how many texture swaps in debug overlay? Currently my android game has 7-8 texture pages per level each 2048*2048. Im afraid its too many or too big to work fine on mediocre and low-end devices. Any help is...
  19. D

    Shader works on Windows and on Android emulator but not on physical Samsung device

    Hi I am building a game and using a shader to enable normal maps on sprites. Everything works fine in test windows platform and in Android emulator, but on Samsung Note 8 Android device it is completely not working. On the Samsung device the shader is not being compiled properly...
Top